Support Questions
Find answers, ask questions, and share your expertise

Metron Install on Ubuntu VM

Has anyone tried installing metron on Ubuntu VM running on Hyper V or Vmware , was able to install all required components but when try to bring the machine with vagrant up get the following error.

There was an error while executing `VBoxManage`, a CLI used by Vagrant for controlling VirtualBox. The command and stderr is shown below. Command: ["startvm", "600074f9-687c-45cc-b684-5d85390e6bf4", "--type", "headless"] Stderr: VBoxManage: error: VT-x is not available (VERR_VMX_NO_VMX) VBoxManage: error: Details: code NS_ERROR_FAILURE (0x80004005), component ConsoleWrap, interface IConsole

Does this mean we cant run Vagrant+virtualbox on a VM?

5 REPLIES 5

Explorer

There seems to be some offending property in your Virtualbox/Vagrant. Something like deactivating "IO-APIC" in System Settings of the VM could make it work

@ankur V FYI: It's recommended to install Metron on CentOS, not on Ubuntu.

Got it working on a bare metal HDP2.5 seems to be a known issues with Virtualbox when installed on a VM. But now i have another issue, i cannot change the "node1" ip address from the default 192.168.66.121 to something that is routed over our internal network tried changing the host file and even the "Vagrantfile" in /metron-deployment/vagrant/full-dev-platform but nothing works.

New Contributor

Dear ankur,

I'm just a new user with Metron and I discussing with other member about the installation of Metron into Ubuntu.

Can you please write more details about the installation?

Which is the Ubuntu's version that you have used?

Which Metron version? 0.3.1 or 0.4.0?

Did you follow any guideline to install all the tools chain?

Thank you.

Simone

Tried on Ubuntu 14 and 16 metron 0.4.0 and there is no issue with the installation and i referred https://cwiki.apache.org/confluence/pages/viewpage.action?pageId=68718548 for installation steps, just make sure to install Docker manually as well before getting to steps to start metron install. Also it depends on how you install some folders need elevated access such as "Virtualbox VM" etc. The only issue I still have on Ubuntu is I cannot bring the metron on the network, there seems to be something missing in the installation or the way it works on Ubuntu. When the metron VM is brought up using Virtual box it runs but the VM is not imported into the Virtualbox just as it does when installed on Centos.

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.