Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Metron Profiler: HbaseBolt not storing data to HBase

Metron Profiler: HbaseBolt not storing data to HBase

Installed metron profiler with the help of this link:

https://metron.apache.org/current-book/metron-analytics/metron-profiler/index.html

Attached my profiler.properties and profiler.json files, remote.yaml and worker.log files.

Once I place the following message into kafka topic 'indexing'

[{"ip_src_addr":"10.0.0.1","protocol":"HTTPS","length":"10","bytes_in":"234"},{"ip_src_addr":"10.0.0.2","protocol":"HTTP","length":"20","bytes_in":"390"},{"ip_src_addr":"10.0.0.3","protocol":"DNS","length":"30","bytes_in":"560"}]

It's picked by splitterBolt and passed till HBaseBolt. But data is not getting stored to Hbase.

metron-artifacts.zip

Attached storm-ui screenshot.storm-ui-screen.png

Please suggest what am I missing here.

Thanks in advance.

2 REPLIES 2
Highlighted

Re: Metron Profiler: HbaseBolt not storing data to HBase

Any help on this please.

Highlighted

Re: Metron Profiler: HbaseBolt not storing data to HBase

Rising Star

Have you been able to follow the "Getting Started" instructions and get that working? http://metron.apache.org/current-book/metron-analytics/metron-profiler/index.html#Getting_Started

Don't have an account?
Coming from Hortonworks? Activate your account here