Support Questions
Find answers, ask questions, and share your expertise

Metron Quick-dev-platform installation timeout error at ​Task - [pycapa : Install dependencies]

Hi,

I am running with below configurations to install Metron Quick-dev-platform:

Managed machine OS - Redhat 7

# ansible --version

ansible 2.0.0.2

# python2.7 -V

Python 2.7.12

Somehow the task - [pycapa : Install dependencies] keeps failing because of timeouts while downloading libgcj-4.4.7-17.el6.x86_64.rpm package. The network connectivity seems to be just fine, according to our network admin.

I want to know if I can comment out the content in: "/metron-deployment/roles/pycapa/tasks/pycapa.yml" so that I can skip pycapa setup completely and Metron would still get installed without any hiccups. Or is it okay to ssh node1 and install this package alone and continue with rest of installation/deployment? Whatever works 🙂

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Metron Quick-dev-platform installation timeout error at ​Task - [pycapa : Install dependencies]

Super Collaborator

Hi @Naveen Maheswaran,

I found the following to be working fine. I tried with a quick dev deployment and it went through fine. Please check if you are able to get similar results in your case.

1) To deploy without pycapa role

- Edit run.sh and add 'pycapa' to the skip tags

(testmetron) ➜  quick-dev-platform git:(master) ✗ pwd
~/Metron/incubator-metron-fork/incubator-metron/metron-deployment/vagrant/quick-dev-platform
(testmetron) ➜  quick-dev-platform git:(master) ✗ tail -5 run.sh
vagrant \
  --ansible-tags="hdp-deploy,metron" \
  --ansible-skip-tags="solr,yaf,pycapa" \
  up

2) Verify /opt/pycapa is absent in the vagrant node

(testmetron) ➜  quick-dev-platform git:(master) ✗ vagrant ssh
Last login: Mon Oct  3 09:14:30 2016 from 192.168.66.1
[vagrant@node1 ~]$ ls /opt/pycapa
ls: cannot access /opt/pycapa: No such file or directory

3) Next deploy 'pycapa' role alone using the vagrant command:

(testmetron) ➜  quick-dev-platform git:(master) ✗ vagrant --ansible-tags="pycapa" provision
 Running with ansible-tags: ["pycapa"]
==> node1: Running provisioner: ansible...
    node1: Running ansible-playbook...
<snip>

4) Now see that the pycapa installables are created under /opt

(testmetron) ➜  quick-dev-platform git:(master) ✗ vagrant ssh
[vagrant@node1 ~]$ ls /opt/pycapa/pycapa*
/opt/pycapa/pycapa:
build  dist  LICENSE  pycapa  pycapa.egg-info  README.md  requirements.txt  setup.py  VERSION

/opt/pycapa/pycapa-venv:
bin  include  lib  lib64  pip-selfcheck.json  share  tests

Let me know if this works.

Cheers,

Anand

View solution in original post

5 REPLIES 5

Re: Metron Quick-dev-platform installation timeout error at ​Task - [pycapa : Install dependencies]

Explorer

@Naveen Maheswaran

If you want to skip the pycapa role installation , you can edit the run.sh file at /metron-deployment/vagrant/quick-dev-platform/run.sh and add "pycapa" to the list of "--ansible-skip-tags".

Your edited run.sh file should look like below :-

vagrant \  

--ansible-tags="hdp-deploy,metron" \  

--ansible-skip-tags="solr,pycapa" \  

up

Run the quick-dev-deployment after making the mentioned changes.

Please let me know if this serves your purpose.

Regards,

Neha

Re: Metron Quick-dev-platform installation timeout error at ​Task - [pycapa : Install dependencies]

Thanks! I don't have sufficient knowledge of Ansible, so pls bare with me.

Can you also let me know if, at a later point, I need to add pycapa, what procedure is to be followed?

In general, how to run skipped ansible tags at a later point in time?

Re: Metron Quick-dev-platform installation timeout error at ​Task - [pycapa : Install dependencies]

Explorer

you can try out the following to deploy pycapa later :-

  1. Navigate to metron-deployment folder
  2. Run the following command if you deployed metron using quick-dev-deployment env earlier
ansible-playbook -i inventory/full-dev-platform --tags=“pycapa” playbooks/metron_full_install -vvv

Note:- you can use the above command to run the skipped ansible tags.Just make sure to provide the tags comma separated to the --tags parameter.

Hope this helps.

Regards,

Neha

Re: Metron Quick-dev-platform installation timeout error at ​Task - [pycapa : Install dependencies]

Thanks for the help, Neha! I was able to set up Metron without pycapa. But now when I try to set up pycapa, I face issues.

I ran the command:

ansible-playbook -i inventory/full-dev-platform --tags=“pycapa” playbooks/metron_full_install.yml -vvv

and encountered this:

Loaded callback default of type stdout, v2.0

21 plays in playbooks/metron_full_install.yml

...

TASK [setup] *******************************************************************

<node1> ESTABLISH SSH CONNECTION FOR USER: None

<node1> SSH: EXEC ssh -C -vvv -o ControlMaster=auto -o ControlPersist=60s -o StrictHostKeyChecking=no -o KbdInteractiveAuthentication=no -o PreferredAuthentications=gssapi-with-mic,gssapi-keyex,hostbased,publickey -o PasswordAuthentication=no -o ConnectTimeout=10 -o ControlPath=/root/.ansible/cp/%h-%p-%r -tt node1 '( umask 22 && mkdir -p "$( echo $HOME/.ansible/tmp/ansible-tmp-1475220609.2-93846986252640 )" && echo "$( echo $HOME/.ansible/tmp/ansible-tmp-1475220609.2-93846986252640 )" )'

...

PLAY RECAP *********************************************************************

node1 : ok=0 changed=0 unreachable=1 failed=0

Looks like it caused unreachable host error because of User: None. Can you have a look?

Re: Metron Quick-dev-platform installation timeout error at ​Task - [pycapa : Install dependencies]

Super Collaborator

Hi @Naveen Maheswaran,

I found the following to be working fine. I tried with a quick dev deployment and it went through fine. Please check if you are able to get similar results in your case.

1) To deploy without pycapa role

- Edit run.sh and add 'pycapa' to the skip tags

(testmetron) ➜  quick-dev-platform git:(master) ✗ pwd
~/Metron/incubator-metron-fork/incubator-metron/metron-deployment/vagrant/quick-dev-platform
(testmetron) ➜  quick-dev-platform git:(master) ✗ tail -5 run.sh
vagrant \
  --ansible-tags="hdp-deploy,metron" \
  --ansible-skip-tags="solr,yaf,pycapa" \
  up

2) Verify /opt/pycapa is absent in the vagrant node

(testmetron) ➜  quick-dev-platform git:(master) ✗ vagrant ssh
Last login: Mon Oct  3 09:14:30 2016 from 192.168.66.1
[vagrant@node1 ~]$ ls /opt/pycapa
ls: cannot access /opt/pycapa: No such file or directory

3) Next deploy 'pycapa' role alone using the vagrant command:

(testmetron) ➜  quick-dev-platform git:(master) ✗ vagrant --ansible-tags="pycapa" provision
 Running with ansible-tags: ["pycapa"]
==> node1: Running provisioner: ansible...
    node1: Running ansible-playbook...
<snip>

4) Now see that the pycapa installables are created under /opt

(testmetron) ➜  quick-dev-platform git:(master) ✗ vagrant ssh
[vagrant@node1 ~]$ ls /opt/pycapa/pycapa*
/opt/pycapa/pycapa:
build  dist  LICENSE  pycapa  pycapa.egg-info  README.md  requirements.txt  setup.py  VERSION

/opt/pycapa/pycapa-venv:
bin  include  lib  lib64  pip-selfcheck.json  share  tests

Let me know if this works.

Cheers,

Anand

View solution in original post