Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Metron vagrant start hadoop services faiing

Solved Go to solution
Highlighted

Metron vagrant start hadoop services faiing

Super Guru

Trying to get a instance of metron up and running. Ambari is up so not sure if things are ok. I performed vagrant up and things went smoothly until task to start hadoop services. here is my error log:

TASK [ambari_config : Start All Hadoop Services node1] *************************
failed: [node1] (item=HDFS) => {"connection": "close", "content": "", "content_type": "text/plain;charset=ISO-8859-1", "failed": true, "item": "HDFS", "msg": "Status code was not [200, 202]: HTTP Error 500: Server Error", "redirected": false, "server": "Jetty(8.1.17.v20150415)", "set_cookie": "AMBARISESSIONID=tbclunfsajxy1bnyfpvk7twl;Path=/;HttpOnly", "status": 500, "url": "http://node1:8080/api/v1/clusters/metron_cluster/services/HDFS", "user": "admin"}
failed: [node1] (item=YARN) => {"connection": "close", "content": "", "content_type": "text/plain;charset=ISO-8859-1", "failed": true, "item": "YARN", "msg": "Status code was not [200, 202]: HTTP Error 500: Server Error", "redirected": false, "server": "Jetty(8.1.17.v20150415)", "set_cookie": "AMBARISESSIONID=1k3byxj6l24791q0zzxpojzmpe;Path=/;HttpOnly", "status": 500, "url": "http://node1:8080/api/v1/clusters/metron_cluster/services/YARN", "user": "admin"}
failed: [node1] (item=MAPREDUCE2) => {"connection": "close", "content": "", "content_type": "text/plain;charset=ISO-8859-1", "failed": true, "item": "MAPREDUCE2", "msg": "Status code was not [200, 202]: HTTP Error 500: Server Error", "redirected": false, "server": "Jetty(8.1.17.v20150415)", "set_cookie": "AMBARISESSIONID=onwvdexdk4x513bjb4tzj0wfz;Path=/;HttpOnly", "status": 500, "url": "http://node1:8080/api/v1/clusters/metron_cluster/services/MAPREDUCE2", "user": "admin"}
failed: [node1] (item=ZOOKEEPER) => {"connection": "close", "content": "", "content_type": "text/plain;charset=ISO-8859-1", "failed": true, "item": "ZOOKEEPER", "msg": "Status code was not [200, 202]: HTTP Error 500: Server Error", "redirected": false, "server": "Jetty(8.1.17.v20150415)", "set_cookie": "AMBARISESSIONID=1n3omygdur23a1tsoo4n49e8xt;Path=/;HttpOnly", "status": 500, "url": "http://node1:8080/api/v1/clusters/metron_cluster/services/ZOOKEEPER", "user": "admin"}
failed: [node1] (item=HBASE) => {"connection": "close", "content": "", "content_type": "text/plain;charset=ISO-8859-1", "failed": true, "item": "HBASE", "msg": "Status code was not [200, 202]: HTTP Error 500: Server Error", "redirected": false, "server": "Jetty(8.1.17.v20150415)", "set_cookie": "AMBARISESSIONID=18uowb8b50qx21vqpumqqasroq;Path=/;HttpOnly", "status": 500, "url": "http://node1:8080/api/v1/clusters/metron_cluster/services/HBASE", "user": "admin"}
failed: [node1] (item=STORM) => {"connection": "close", "content": "", "content_type": "text/plain;charset=ISO-8859-1", "failed": true, "item": "STORM", "msg": "Status code was not [200, 202]: HTTP Error 500: Server Error", "redirected": false, "server": "Jetty(8.1.17.v20150415)", "set_cookie": "AMBARISESSIONID=10s5zpez54rti1ol96n7f2orhh;Path=/;HttpOnly", "status": 500, "url": "http://node1:8080/api/v1/clusters/metron_cluster/services/STORM", "user": "admin"}
failed: [node1] (item=KAFKA) => {"connection": "close", "content": "", "content_type": "text/plain;charset=ISO-8859-1", "failed": true, "item": "KAFKA", "msg": "Status code was not [200, 202]: HTTP Error 500: Server Error", "redirected": false, "server": "Jetty(8.1.17.v20150415)", "set_cookie": "AMBARISESSIONID=g7746coyq9kindh256rofz7v;Path=/;HttpOnly", "status": 500, "url": "http://node1:8080/api/v1/clusters/metron_cluster/services/KAFKA", "user": "admin"}
to retry, use: --limit @../../playbooks/metron_full_install.retry
PLAY RECAP *********************************************************************
node1                      : ok=38changed=28   unreachable=0    failed=1

Ansible failed to complete successfully. Any error output should be

visible above. Please fix these errors and try again.

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Metron vagrant start hadoop services faiing

New Contributor

Ok, I just saw with one with a member of the team here on Metron who has a new machine. I think the issue is our ansible scripts interacting negatively with ansible version 2.0.2. All of the members of the team here have 2.0.0.2. While this is corrected, I would suggest reverting to 2.0.0.2 and letting me know if it fixes the issue.

In case you might not know how to do that, what *I* do is remove ansible from homebrew (brew uninstall ansible) and then install directly via pip (pip install ansible==2.0.0.2).

Let me know and sorry for the bug!

17 REPLIES 17

Re: Metron vagrant start hadoop services faiing

Rising Star

Have you logged into Ambari to check it out? Try logging into http://node1:8080 as admin/admin. What does that look like? Do you see much red?

Re: Metron vagrant start hadoop services faiing

Super Guru

@nallen I have logged into ambari and no red. All looks good. No storm topologies running.

Re: Metron vagrant start hadoop services faiing

Rising Star

A log should exist at 'deployment/vagrant/singlenode-vagrant/ansible.log'. Can you attach that here in HCC?

Re: Metron vagrant start hadoop services faiing

Super Guru

Re: Metron vagrant start hadoop services faiing

New Contributor

Getting the same exact error and the ansible.log looks the same.

Re: Metron vagrant start hadoop services faiing

Expert Contributor

The ansible playbook failed at the end of ambari_install.yml with Ambari & HDP running, so I re-provisioned the single-node cluster with the second half of the playbook: the metron_install.yml script. That deployed all four topologies and the Metron UI. I saw an error in the HDFS section of hadoop_setup so I reran/re-provisioned that part, and now I'm seeing data in the Metron UI. My guess is that the playbook timed out before the HDP components had time to come up. Next I'm going to suspend the VMs before my Mac melts down... the fan's pegged! :)

Re: Metron vagrant start hadoop services faiing

New Contributor

What laptop are you running this on? I've never gotten this issue and I build this at least once a day. Maybe the older hardware has issues with our VM?

Re: Metron vagrant start hadoop services faiing

Expert Contributor

@jsirota, maybe so! MacBook Pro, 2.5 GHz i7 with 16 GB of memory, OS X 10.9.5, vanilla VirtualBox config.

Re: Metron vagrant start hadoop services faiing

Guru

Same exact error here too. From Ambari server logs,

Below is the log from ambari-server log which has an error.

metronambariserver.txt

Don't have an account?
Coming from Hortonworks? Activate your account here