Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here. Want to know more about what has changed? Check out the Community News blog.

Microstrategy Cube creation problem in IMPALA

Microstrategy Cube creation problem in IMPALA

New Contributor

Hi all,

When we create a cube with some temporary tables in Impala the sequence is as follows:
1.  Create a table
2.  Insert data in the table.
3.  Select data  from the table to publish the cube
4.  Drop the table 


The issue is that when we try to publish the data in the cube, sometimes 0 rows are published and sometimes 200 rows are published.
All the rows are not able to publish in the cube.

It seems that the Select is executed before Insert is finished.

The same sequence is working with  another database for publishing the cubes.

Can anybody suggest how to resolve this issue.

Is it problem with Microstrategy or is it problem with Impala ?

Regards

10 REPLIES 10
Highlighted

Re: Microstrategy Cube creation problem in IMPALA

Cloudera Employee
Hi,
What version of Impala are you running and what version of the Impala ODBC
Driver/Microstrategy Connector are you using?

Thanks,
Lenni

Re: Microstrategy Cube creation problem in IMPALA

New Contributor

I am using Impala 1.1.1

Re: Microstrategy Cube creation problem in IMPALA

New Contributor

 The version of the ODBC driver that we are using is ClouderaHiveODBC_v2_00 for Linux

Re: Microstrategy Cube creation problem in IMPALA

Cloudera Employee
Hi Dilip,
I believe there was a bug in older versions of the driver that did not
properly wait for an INSERT statement to complete (it assume one of the
APIs was synchronous when it was actually asynchronous). Can you try
updating to the latest driver and seeing if your problem is resolved:
http://www.cloudera.com/content/support/en/downloads/connectors/impala/impala-odbc-v2-5-17.html

I also highly recommend upgrading to the latest version of Impala (v1.4),
as we have made many improvements and bug fixes over v1.1.1.

Thanks,
Lenni

Re: Microstrategy Cube creation problem in IMPALA

Cloudera Employee

Dilip – and what version of MSTR is this? Also, have you assured that the MSTR VLDB object for Impala is installed and configured?

Re: Microstrategy Cube creation problem in IMPALA

New Contributor

We are using MSTR 9.3.1 

Re: Microstrategy Cube creation problem in IMPALA

New Contributor
Thank you Lenni.

Re: Microstrategy Cube creation problem in IMPALA

New Contributor

Could anybody please explain how to install and configure  MSTR VLDB object for Impala. 

 

Thanks,

Dilip.

Re: Microstrategy Cube creation problem in IMPALA

Cloudera Employee
Hi Dilip,

The MSTR forum or support is probably a better venue for MSTR
install/config questions.

Thanks!