Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

My NameNode UI is not accessible on my kerbereized cluster

Highlighted

My NameNode UI is not accessible on my kerbereized cluster

New Contributor

Hello,

I've successfully enabled kerberos on my cluster. All the services are running correctly.

When i try to access to my NameNode UI by taping http://ambari:50070 on my browser, i got the error mentioned in error.png.

- My ambari server is running with root user. So,i resecured my cluster with root@MYREALM and made all the necessary configurations by following this link:

https://docs.hortonworks.com/HDPDocuments/Ambari-2.4.1.0/bk_ambari-security/content/set_up_kerberos_....

- I've also enabled SPNEGO authentication for Hadoop by following these links:

https://docs.hortonworks.com/HDPDocuments/Ambari-2.2.1.1/bk_Ambari_Security_Guide/content/_configuri... and

https://developer.ibm.com/hadoop/2016/09/28/securing-hadoop-user-interfaces-kerberos-enable/.

- I'm working on local domain. So, i've not FQDN. My cluster is composed of two hosts whose hostnames are ambari and ambari-slave1. Hence, i didn't set hadoop.http.authentication.cookie.domain in Custom core-site.

- I've enabled browser access to a SPNEGO-enabled web UI by following this link:

https://docs.hortonworks.com/HDPDocuments/Ambari-2.6.0.0/bk_ambari-security/content/enabling_browser.... At this step, i've skipped 1. 2. and 3. because my kerberos is already installed and automatically configured. The 4. sub-step is done as mentioned in step.png.

My question are:

- Which eventual steps are missed?

- How can i resolve this issue?

I'm really stuck at this final step of securing my cluster. I'll be grateful if someone could help me.

1 REPLY 1

Re: My NameNode UI is not accessible on my kerbereized cluster

New Contributor

i have same the problem, how can i resolve this issue?