Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

My sandbox on azure stopped working

Highlighted

My sandbox on azure stopped working

Contributor

After restarting the sandbox on azure ambari is not working hbase gives an exception connection refused with zookeeper refuse connection any suggestions how to resolve this?

10 REPLIES 10
Highlighted

Re: My sandbox on azure stopped working

@Avraha Zilberman

Please follow this

Login to ambari

Start

Hdfs

Mapreduce

Yarn

Zk

HBase

And other services

It should work

Highlighted

Re: My sandbox on azure stopped working

Mentor

@Avraha Zilberman start zookeeper first and then go down the list with hdfs, mapred, etc. ZK first before HBase that's general knowledge.

Highlighted

Re: My sandbox on azure stopped working

Mentor

@Avraha Zilberman first check the database is up and running. Ambari wont load if not connected to the back end DB

Highlighted

Re: My sandbox on azure stopped working

@Avraha Zilberman This is very good point. If DB is down then ambari wont be able to start

Highlighted

Re: My sandbox on azure stopped working

Rising Star
@Avraha Zilberman

what size machine did you use and wondering if you followed a tutorial to hit this behavior?

Highlighted

Re: My sandbox on azure stopped working

Contributor

yes I know

I started the zk but didnt help

,

I cant login to ambari..

Because it is not available

Highlighted

Re: My sandbox on azure stopped working

Mentor

@Avraha Zilberman can you please paste in here the ambari logs

Highlighted

Re: My sandbox on azure stopped working

Contributor

Here is the log of zookeeper look like file damage but I don't know which one.

java.io.EOFException

at java.io.DataInputStream.readInt(DataInputStream.java:392)

at org.apache.jute.BinaryInputArchive.readInt(BinaryInputArchive.java:63)

at org.apache.zookeeper.server.persistence.FileHeader.deserialize(FileHeader.java:64)

at org.apache.zookeeper.server.persistence.FileTxnLog$FileTxnIterator.inStreamCreated(FileTxnLog.java:576)

at org.apache.zookeeper.server.persistence.FileTxnLog$FileTxnIterator.createInputArchive(FileTxnLog.java:595)

at org.apache.zookeeper.server.persistence.FileTxnLog$FileTxnIterator.goToNextLog(FileTxnLog.java:561)

at org.apache.zookeeper.server.persistence.FileTxnLog$FileTxnIterator.next(FileTxnLog.java:643)

at org.apache.zookeeper.server.persistence.FileTxnSnapLog.restore(FileTxnSnapLog.java:158)

at org.apache.zookeeper.server.ZKDatabase.loadDataBase(ZKDatabase.java:223)

at org.apache.zookeeper.server.ZooKeeperServer.loadData(ZooKeeperServer.java:272)

at org.apache.zookeeper.server.ZooKeeperServer.startdata(ZooKeeperServer.java:399)

at org.apache.zookeeper.server.NIOServerCnxnFactory.startup(NIOServerCnxnFactory.java:122)

at org.apache.zookeeper.server.ZooKeeperServerMain.runFromConfig(ZooKeeperServerMain.java:113)

at org.apache.zookeeper.server.ZooKeeperServerMain.initializeAndRun(ZooKeeperServerMain.java:86)

at org.apache.zookeeper.server.ZooKeeperServerMain.main(ZooKeeperServerMain.java:52)

at org.apache.zookeeper.server.quorum.QuorumPeerMain.initializeAndRun(QuorumPeerMain.java:116)

at org.apache.zookeeper.server.quorum.QuorumPeerMain.main(QuorumPeerMain.java:78)

Highlighted

Re: My sandbox on azure stopped working

Mentor

@Avraha Zilberman the ambari logs are here

Don't have an account?
Coming from Hortonworks? Activate your account here