Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

NIFI service don't start after enable SSL

NIFI service don't start after enable SSL

New Contributor

Hi, Can someone help me?

109703-whatsapp-image-2019-06-30-at-060804.jpeg

2 REPLIES 2

Re: NIFI service don't start after enable SSL

Super Mentor

@Marcelo Souza

Can you please share the nifi logs from the starting of NiFi process so that we can check what is failing.

Also are you able to start NiFi using command line?

https://docs.hortonworks.com/HDPDocuments/HDF3/HDF-3.4.0/installing-upgrading-nifi/content/starting_...

Re: NIFI service don't start after enable SSL

New Contributor

Hello Jay, how's it going?

By the command line it does not start the service I'm using Ambari to do this!

I was able to start the services, however I am now having problems configuring LDAP. It's the first time I do this, I'm about 6 days trying without success.

109666-1561954269845.png


this is authorizers.xml

<authorizers>

<userGroupProvider>

<identifier>file-user-group-provider</identifier>

<class>org.apache.nifi.authorization.FileUserGroupProvider</class>

<property name="Users File">/var/lib/nifi/conf/users.xml</property>

<property name="Legacy Authorized Users File"></property>

<property name="Initial User Identity 0">CN=nifi_user,CN=Users,DC=br,DC=xxxxx</property>

<property name="Initial User Identity 1">CN=aslxub34az, OU=NIFI</property>

<property name="Initial User Identity 2">CN=aslxub35az, OU=NIFI</property>

<property name="Initial User Identity 3">CN=aslxub36az, OU=NIFI</property>

<property name="Initial User Identity 4">CN=aslxub37az, OU=NIFI</property>

<property name="Initial User Identity 5">CN=aslxub38az, OU=NIFI</property>

</userGroupProvider>


<accessPolicyProvider>

<identifier>file-access-policy-provider</identifier>

<class>org.apache.nifi.authorization.FileAccessPolicyProvider</class>

<property name="User Group Provider">file-user-group-provider</property>

<property name="Authorizations File">/var/lib/nifi/conf/authorizations.xml</property>

<property name="Initial Admin Identity">CN=nifi_user,CN=Users,DC=br,DC=xxxxx</property>

<property name="Legacy Authorized Users File"></property>

<property name="Node Identity 1">CN=aslxub34az, OU=NIFI</property>

<property name="Node Identity 2">CN=aslxub35az, OU=NIFI</property>

<property name="Node Identity 3">CN=aslxub36az, OU=NIFI</property>

<property name="Node Identity 4">CN=aslxub37az, OU=NIFI</property>

<property name="Node Identity 5">CN=aslxub38az, OU=NIFI</property>

</accessPolicyProvider>


<authorizer>

<identifier>file-provider</identifier>

<class>org.apache.nifi.authorization.StandardManagedAuthorizer</class>

<property name="Access Policy Provider">file-access-policy-provider</property>

</authorizer>

</authorizers>


this is login-identity-provider.xml

<provider>

<identifier>ldap-provider</identifier>

<class>org.apache.nifi.ldap.LdapProvider</class>

<property name="Authentication Strategy">SIMPLE</property>

<property name="Manager DN">CN=nifi_user,CN=Users,DC=br,DC=xxxxx</property>

<property name="Manager Password">xxxxx@10</property>

<property name="Referral Strategy">FOLLOW</property>

<property name="Connect Timeout">10 secs</property>

<property name="Read Timeout">10 secs</property>

<property name="Url">ldap://xxx.xx.xx.xx</property>

<property name="User Search Base">DC=br,DC=xxxxx</property>

<property name="User Search Filter">sAMAccountName={0}</property>

<property name="Identity Strategy">USE_USERNAME</property>

<property name="Authentication Expiration">12 hours</property>

</provider>