Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Namenode unable to start - Ranger issue in namenode HA configuration

Solved Go to solution

Namenode unable to start - Ranger issue in namenode HA configuration

Super Guru

I have namenode HA configured with Kerberos authentication, when ranger hdfs plugin is disabled, my hdfs services are running fine, when I enable ranger HDFS plugin then my namenode is unable to come up because of below error:

File "/usr/lib/python2.6/site-packages/ambari_simplejson/decoder.py", line 353, in raw_decode raise 
ValueError("No JSON object could be decoded")
ValueError: No JSON object could be decoded 

I know there is know issue - if we change ranger admin UI password, then we also need to modify the same password in admin_password field under advance_ranger_configs section via Ambari UI. I tried doing the same thing but its not working.

Anyone has any idea or has seen this issue in past ?

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Namenode unable to start - Ranger issue in namenode HA configuration

8 REPLIES 8

Re: Namenode unable to start - Ranger issue in namenode HA configuration

Can you look into ambari and hdfs logs and check whether their is any message that has more details, especially what file/object Ambari is trying to decode?

Do you see a repository for HDFS in Ranger?

I have a cluster with NN HA and Ranger HDFS plugin enabled running on HDP 2.3.2 and Ambari 2.1.2.1 without any issues.

Edit: What version of HDP and Ambari do you have?

Re: Namenode unable to start - Ranger issue in namenode HA configuration

Super Guru

Sure I will check. I have HDP 2.3.2 and Ambari 2.1.1

Re: Namenode unable to start - Ranger issue in namenode HA configuration

Contributor

Can you make sure that the password for amb_ranger_admin in RangerAdmin->User is the same as in Ambari -> Ranger -> Config -> Ambari Admin User

Re: Namenode unable to start - Ranger issue in namenode HA configuration

Super Guru

I tried changing password for amb_ranger_admin however no luck. will update you once I get it working

Re: Namenode unable to start - Ranger issue in namenode HA configuration

Mentor

@Kuldeep Kulkarni has this been resolved? Please accept best answer or provide your own solution.

Re: Namenode unable to start - Ranger issue in namenode HA configuration

Expert Contributor

Hello

I came across your problem and it seems to be a major issue. I've posted a question regarding this issue. We use Ranger for managing hive authorizations - and after changing the Ranger Admin password we can no longer use it for that. To be more precise - HiveServer2 won't start unless we disable Ranger as the authorization manager for hive in Ambari. More details in my post: https://community.hortonworks.com/questions/14329/hiveserver2-wont-start-after-changing-rangers-admi...

I really hope someone will fix this bug.

Adi

Re: Namenode unable to start - Ranger issue in namenode HA configuration

Re: Namenode unable to start - Ranger issue in namenode HA configuration

New Contributor

Hello

I'm having the same problem.

After changing ranger admin password in ranger & in ambari (under ambari ranger config) hive server won't start.

I get No json object could be decoded.

Only if I disable ranger from hive authorization it starts.

Hdp 2.3.2

Ambari 2.1.2.1

Any help would appreciated.

Adi