Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Need help resolving [HiveODBC] (68) Error returned trying to set default as the initial database: ETIMEDOUT;

Solved Go to solution

Need help resolving [HiveODBC] (68) Error returned trying to set default as the initial database: ETIMEDOUT;

New Contributor

Hi..

When connecting to a Hive Server, I am getting the following error

[Hortonworks][HiveODBC] (68) Error returned trying to set default as the initial database: ETIMEDOUT; Also tried quoting the database name `default` but the query failed with the following error: ETIMEDOUT

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Need help resolving [HiveODBC] (68) Error returned trying to set default as the initial database: ETIMEDOUT;

@hal lavender

Make sure that you are able to reach HS2 port from the client. You can run the following test

telnet hs2servername 10000 to verify

View solution in original post

2 REPLIES 2
Highlighted

Re: Need help resolving [HiveODBC] (68) Error returned trying to set default as the initial database: ETIMEDOUT;

@hal lavender

Make sure that you are able to reach HS2 port from the client. You can run the following test

telnet hs2servername 10000 to verify

View solution in original post

Highlighted

Re: Need help resolving [HiveODBC] (68) Error returned trying to set default as the initial database: ETIMEDOUT;

Mentor
@Hal

are you still having issues with this? Can you accept best answer or provide your own solution?

Don't have an account?
Coming from Hortonworks? Activate your account here