Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Need python version > 2.6 Apache Ambari

Highlighted

Need python version > 2.6 Apache Ambari

New Contributor

While trying to stop apache amabari server I am getting following error: "Need python version > 2.6" But the command :python --version is showing Python 2.7.5

I am using rhel 7 ec2 instance, apache ambari 2.4.1.0 and HDP 2.5. I just want to reset apache ambari server. Please help me. Thanks

2 REPLIES 2

Re: Need python version > 2.6 Apache Ambari

Super Mentor

@Shemeem SP

How are you stoping ambari-server? Are you mixing "systemctl" and "ambari-server" commands?

By any chance you are using "systemctl" to check status, start and stop ambari?

If yes then can you try the following sequence and then share the results?

# systemctl stop ambari-server.service 
# systemctl status ambari-server.service 
# systemctl start ambari-server.service 
# systemctl status ambari-server.service 

You can also use the following commands to start stop

# ambari-server stop
# ambari-server status 
# ambari-server start
# ambari-server status 

.

Please share the complete output of above sequence of commands if you face any issue related to python.

Also please share the output of the RPM version as following:

rpm -qa | grep ambari

.

Re: Need python version > 2.6 Apache Ambari

New Contributor

@Jay SenSharma

Thanks for your reply.

I was getting this error while stopping server using "ambari-server stop" command.

As of now,I started installation again with fresh server, I will not be able to execute the above command.

Thanks for your time.

Don't have an account?
Coming from Hortonworks? Activate your account here