Support Questions
Find answers, ask questions, and share your expertise

Need suggestion regarding HDP and Ambari upgrade.

Contributor

Hi All,

I'm planning to upgrade ambari version from 2.2.2 to 2.5.1 and for HDP from 2.4.3 to 2.6.1 is it recommended to upgrade in this same manner, or better to go with lower version upgrade example, ambari 2.2.2 to 2.3.x & to 2.4.x and for HDP 2.4.x to 2.5.x & to 2.6.x. Since im planning to upgrade in production environment i need this clarification.kindly suggest.

Regards,

Mathi

3 REPLIES 3

Re: Need suggestion regarding HDP and Ambari upgrade.

Super Mentor

@Mathi Murugan

The following doc suggest the Upgrade Path that is supported:

https://docs.hortonworks.com/HDPDocuments/HDP2/HDP-2.6.1/bk_support-matrices/content/ch_matrices-amb...

39942-upgrade-path.png

.

First you will have to Upgrade your Ambari to 2.5.1 (Better if you can plan to upgrade to Ambari 2.5.2 as that is the latest) And then you can upgrade the HDP.

Re: Need suggestion regarding HDP and Ambari upgrade.

Super Mentor

Ambari 2.5 does not support managing an HDP 2.2, 2.1 or 2.0 cluster. If you are running HDP 2.2, 2.1 or 2.0, in order to use Ambari 2.5 you must first upgrade to HDP 2.3 or higher using either Ambari 2.4.2, 2.2.2, 2.2.1, 2.2, 2.1, or 2.0 before upgrading to Ambari 2.5. Once completed, upgrade your current Ambari to Ambari 2.5.

Re: Need suggestion regarding HDP and Ambari upgrade.

Super Mentor