Support Questions
Find answers, ask questions, and share your expertise

NiFi GetTwitter

Solved Go to solution

NiFi GetTwitter

New Contributor

I have a simple question, as I am new to NiFi.

I have a GetTwitter processor set up and configured (assuming correctly). I have the Twitter Endpoint set to Sample Endpoint. I run the processor and it runs, but nothing happens. I get no input/output

How do I troubleshoot what it is doing (or in this case not doing)?

1 ACCEPTED SOLUTION

Accepted Solutions

Re: NiFi GetTwitter

@Francis Apel not sure if it applies but I originally had trouble copying and pasting my Twitter api secure tokens. I would paste it and it would stay greyed out and not apply the changes. I solved this by pasting the tokens and then hitting the space bar. When the value is no longer greyed out then you know it has been applied. I would also be sure to set a filter to something which you know will generate lots of twitter data. Maybe something like #trump #clinton or something.

View solution in original post

6 REPLIES 6

Re: NiFi GetTwitter

Contributor

Can you post a picture of your configuration here?

Re: NiFi GetTwitter

Mentor

You need a destination, choose putFile for example and connect the processors with success relationship, then make sure directory exists on filesystem. Once done, start both processors. Take a look at this example for getTwitter https://community.hortonworks.com/articles/1282/sample-hdfnifi-flow-to-push-tweets-into-solrbanana.h...

Re: NiFi GetTwitter

@Francis Apel not sure if it applies but I originally had trouble copying and pasting my Twitter api secure tokens. I would paste it and it would stay greyed out and not apply the changes. I solved this by pasting the tokens and then hitting the space bar. When the value is no longer greyed out then you know it has been applied. I would also be sure to set a filter to something which you know will generate lots of twitter data. Maybe something like #trump #clinton or something.

View solution in original post

Re: NiFi GetTwitter

New Contributor

@Scott Shaw

I took your advice and reentered my tokens, just in case. It now works! Thanks for your help.

Re: NiFi GetTwitter

@Francis Apel Awesome! Glad to hear it and thanks for letting everyone know it worked.

Re: NiFi GetTwitter

New Contributor

@Artem and @Scott Shaw,

Thank you for the replies. I believe I have it configured correctly, as I get the red box and I am able to run it successfully. The problem is that when I run it nothing happens. It sits there with the green arrow, running, but nothing flows in. Is there a log file or any other information that will show me what it is doing, when I don't get any tweets?

Thanks again.