Support Questions
Find answers, ask questions, and share your expertise

NiFi InvokeHTTP Post Fails Silently

Highlighted

NiFi InvokeHTTP Post Fails Silently

New Contributor

Hello,

 

I am new to NiFi and am trying to setup an InvokeHTTP processor to get a bearer token from an API. I can get the token using cURL on the same server as NiFi is installed on but I cannot get it to work in NiFi.

 

To simplify the testing I am just trying to get a response from the API. If I run https://api.karmak.io/auth/connect/token on a web browser I get the following response:
{"error":"invalid_request"}

 

Running the processor does not give any response and no errors or log entries (that I can find) beyond stating that the processor was started and stopped (located in nifi-app.log).

 

The logs I have found are:
/opt/nifi/logs/nifi-app.log
/opt/nifi/logs/nifi-bootstrap.log
/opt/nifi/logs/nifi-user.log

 

I have set the InvokeHTTP processor to DEBUG and these are the properties:InvokeHTTPSettings.png

 

For the SSL Context Service I have tried the Java certificates located at:
/usr/lib/jvm/java-8-openjdk-amd64/jre/lib/security/cacerts

 

I have also created a pkcs12 trustore using the Ubuntu CA certificates and also tried converting that pkcs12 file to a jks file as described by @michal_klempa in the following thread:
https://community.cloudera.com/t5/Support-Questions/Connecting-to-DataSift-HTTPS-API-using-NiFi-GetH... 

 

I still get no error or response. These are the SSL Context Service properties:

 

SSL Context ServiceSSL Context Service


Thank you for you assistance,
James