Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

NiFi LDAP not working

NiFi LDAP not working

Contributor

I have setup the NiFi to use LDAP(AD) with no configuration issues. But It did not laoding the login page, instead its logging in anonymously like before LDAP. I did not see any issues in the log. Can some one help me fix it.

Thnaks,

Suri

5 REPLIES 5
Highlighted

Re: NiFi LDAP not working

@Surya Nuthalapati

Did you configure NiFi to use the ldap-provider in the property nifi.security.user.login.identity.provider= ?

Re: NiFi LDAP not working

Contributor

hi @Wynner, thanks for the reply. Yes, I have set nifi.security.user.login.identity.provider as ldap-provider.

login-identity-providers.xml as:

<?xml version="1.0" encoding="UTF-8" standalone="yes"?> <loginIdentityProviders> <provider> <identifier>ldap-provider</identifier> <class>org.apache.nifi.ldap.LdapProvider</class> <property name="Authentication Strategy">SIMPLE</property> <property name="Manager DN">CN=Administrator,CN=Users,DC=LABHADOOP,DC=COMPANY,DC=COM</property> <property name="Manager Password">COMPANY2017</property> <property name="Referral Strategy">FOLLOW</property> <property name="Connect Timeout">10 secs</property> <property name="Read Timeout">10 secs</property> <property name="Url">ldap://xx.xx.xx.xx:389</property> <property name="User Search Base">CN=Users,DC=LABHADOOP,DC=COMPANY,DC=COM</property> <property name="User Search Filter">sAMAccountName={0}</property> <property name="Identity Strategy">USE_USERNAME</property> <property name="Authentication Expiration">12 hours</property> </provider> </loginIdentityProviders>

But for some reason its not prompting login page and no errors in logs.

Thanks,

Suri

Re: NiFi LDAP not working

Contributor

I am not using SSL on NiFi/LDAP connection.

Re: NiFi LDAP not working

@Surya Nuthalapati

That is why you're not getting prompted to login. You must enabale SSL in NiFi for LDAP to work.

Re: NiFi LDAP not working

Contributor

Thank you @Wynner. I will try to setup SSL and see if it work.

Don't have an account?
Coming from Hortonworks? Activate your account here