Support Questions

Find answers, ask questions, and share your expertise

NiFi SSL problem

Rising Star

Hello,

I created keystore and truststore files from pfx file, did settings in nifi.properties as below;

nifi.security.keystore=my_keystore_file
nifi.security.keystoreType=JKS
nifi.security.keystorePasswd=mypass
nifi.security.keyPasswd=mypass
nifi.security.truststore=my_truststore_file
nifi.security.truststoreType=JKS
nifi.security.truststorePasswd=mypass

I enabled https, disabled http etc. When I start nifi there is no error log in app.log and bootstrap.log, everything seems work but UI doesn't work.

77844-capture.png

2 REPLIES 2

Guru

Hi @Mustafa Kemal MAYUK

I used the NiFi toolkit to generate my nifi.properties, keystore and truststore files, but some things you might want to check with your install/config files can be found in the "NiFi Configuration" section of the following article:

https://community.hortonworks.com/content/kbentry/171173/setting-up-a-secure-nifi-to-integrate-with-...

Master Guru

@Mustafa Kemal MAYUK

Where did you get the client certificate you loaded in to your browser? Is that client cert trusted by the truststore.jks "my_truststore_file" you are using in your Nifi instance?

-

I am also not use to seeing port 9090 used for secure connections (9090 is the default http port used by HDF)

Verify that you have properly set the following nifi.properties keys:

nifi.web.http.host=
nifi.web.http.network.interface.default=
nifi.web.http.port=
nifi.web.https.host=my-server-hostname
nifi.web.https.network.interface.default=
nifi.web.https.port=9091

-

Thank you,

Matt

-

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.