Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

NiFi Web UI not working - ERR_CONNECTION_REFUSED

NiFi Web UI not working - ERR_CONNECTION_REFUSED

Contributor

Today I encountered an error with NiFi that I have never seen before. We have been successfully running NiFi, managed by Ambari, for a number of months now. This morning while working in NiFi, the UI suddenly died. When refreshing the UI, I get ERR_CONNECTION_REFUSED. I have tried this in both Chrome and Explorer, so it is not a browser specific issue.

I have now spent the morning trying to solve this issue. I can give the following info:

  • NiFi is managed by Ambari. According to Ambari NiFi is up
  • NiFi is SSL secured. This is not a security issue, since when switching off SSL Authentication and restarting Ambari, the non-secure UI gives the same issue
  • Our network team has confirmed that this is not a firewall issue - port 9091 is not blocked, but is refusing all connections.
  • selinux is disabled
  • ps -ef | grep nifi shows NiFi is up and running on the machine
  • bin/nifi.sh status shows 2017-06-06 11:34:47,657 INFO [main] org.apache.nifi.bootstrap.Command Apache NiFi is currently running, listening to Bootstrap on port 51190, PID=13513
  • nifi-app.log stops writing anything shortly after startup. The last line is 2017-06-06 11:16:28,561 INFO [main] o.a.nifi.util.FileBasedVariableRegistry Loaded a total of 96 properties. Including precedence overrides effective accessible registry key size is 96 (That was nearly half an hour ago. Nothing since)

I have restart NiFi a number of times trying to solve this, but this has no effect. Any help would be greatly appreciated.

3 REPLIES 3

Re: NiFi Web UI not working - ERR_CONNECTION_REFUSED

New Contributor

I am facing the same issue. Any help would be greatly appreciated.

Highlighted

Re: NiFi Web UI not working - ERR_CONNECTION_REFUSED

Contributor

My problem went away on it's own strangely. I left it without restarting and about 5 hours after the most recent restart everything was back to normal. For some reason the start up was very slow. Since then I've had to restart once, and that was quick. Sorry I can't help.

Re: NiFi Web UI not working - ERR_CONNECTION_REFUSED

Expert Contributor

Any ideas as to why the UI drops connections?

Don't have an account?
Coming from Hortonworks? Activate your account here