Support Questions
Find answers, ask questions, and share your expertise

NiFi queues too large?

Explorer

I pulled in a large number of files into nifi using the getFile processor... I am looking to store these files in HDFS using putHDFS. The process ran overnight and didn't have any back pressure set so the queue got backed up. It seems that this is causing threads to hang when trying to start any processor.

I am also unable to empty the queue... the process just hangs indefinitely at 0%.

Some things I have tried so far:

  1. Restarting Server (removes hanged threads, but threads hang whenever processors are started again)
  2. Increasing Java heap size to 16g
  3. Using G1GC garbage collector
  4. Increasing swap size of queue to 40,000 since both of the backed up queues have 29,000 (8GB) - 25,000 (800MB compressed) flow files in them respectively.

Does anyone have any suggestions for what I should do next? Has anyone run into this issue before? I am on nifi version 0.6.1. Thanks for you help! 🙂

1 ACCEPTED SOLUTION

Do you still have the original source of data outside of NiFi?

If so, you could completely wipe your NiFi back to a clean slate by stoping NiFi and deleting all of the "_repository" directories and restarting. Then you could configure appropriate back-pressure before trying to pick up these files again.

If that is not an option you probably need to figure out what is causing things to hang, is it going out of memory and showing exceptions in the nifi-app.log?

View solution in original post

2 REPLIES 2

Do you still have the original source of data outside of NiFi?

If so, you could completely wipe your NiFi back to a clean slate by stoping NiFi and deleting all of the "_repository" directories and restarting. Then you could configure appropriate back-pressure before trying to pick up these files again.

If that is not an option you probably need to figure out what is causing things to hang, is it going out of memory and showing exceptions in the nifi-app.log?

Explorer

This worked for me in combination with restarted ActiveMQ... thanks!

; ;