Support Questions

Find answers, ask questions, and share your expertise
Announcements
Celebrating as our community reaches 100,000 members! Thank you!

No KeyVersion exists for key 'encryptionkey' after OS patching

avatar
Contributor

After OS patching, people are unable to write/copy the data into the encrypted zones. can any one know how to resolve this?

Here is the error:

copyFromLocal: java.util.concurrent.ExecutionException: java.io.IOException: com.google.common.util.concurrent.UncheckedExecutionException: java.lang.NullPointerException: No KeyVersion exists for key 'encryptionkey'

1 ACCEPTED SOLUTION

avatar
Contributor
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login
8 REPLIES 8

avatar
Master Mentor

@raghavendra v

To be able to help you need to share

  • HDP version
  • OS type and versions
  • Cluster type (single/multi-node)
  • Cluster Size(affected nodes)

Just an important info you have.

avatar
Contributor
  • HDP version-- 2.6.2.0
  • OS type and versions--redhat, 7.5
  • Cluster type (single/multi-node)--multinode cluster(no kerberos)
  • Cluster Size(affected nodes)- 11nodes(ALL)cluster is up and running and can retrieve the data but cannot copt/put the data into the cluster.

avatar
Master Mentor

@raghavendra v

Do you have GUI on the servers?

If not can you install because you will have to boot from the old kernel and backup the directory where your KMS keys?

avatar
Contributor

@Geoffrey Shelton Okot

we are not authorized to use GUI. Is there any way to overcome this issue?

avatar
Master Mentor

@raghavendra v

I understand but but rollback to the previous version you will need the GUI to swtch between the GRB version you could install and uninstall there after ?

If not then ask you SYSOPS team to do that 🙂

avatar
Contributor

@Geoffrey

roll back to previous version of OS(7.4) ?

avatar
Contributor
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login

avatar
Explorer

Hi @raghu9raghavend , did you manage to upgrade Java to the latest version or any version above 8u161? We are getting the same error, any versions below 8u161 doesn't give this error but once upgraded to any versions above 8u161, that is the time the error is showing.