Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

No package ambari-agent available.

Highlighted

No package ambari-agent available.

Expert Contributor

Hi, when trying to add a host through ambari i got the error below,

Running setup agent script...
==========================

Command start time 2016-11-20 15:09:29
Error: No matching Packages to list
Error: No matching Packages to list 
('', None)

When i try to add the agent manually, i downloaded the repo. 
wget -nv http://public-repo-1.hortonworks.com/ambari/
centos7/2.x/updates/2.2.2.0/ambari.repo -O /etc/yum.repos.d/
ambari.repo

When i enter " yum repolist" it shows i have the ambari repo there. 
repo id                             repo name                             status
Updates-ambari-2.2.2.0              ambari-2.2.2.0 - Updates                  8

But when i enter "yum install ambari-agent"

I get 
No package ambari-agent available.
Error: Nothing to do

"rpm -qa | grep ambari-agent" returns nothing


4 REPLIES 4
Highlighted

Re: No package ambari-agent available.

Contributor
@Roger Young

Could you please try this command and advise?

yum --enablerepo=* install ambari-agent

Re: No package ambari-agent available.

Expert Contributor

Hi, the command returned the following.

Loaded plugins: fastestmirror
http://vault.centos.org/7.0.1406/os/armhfp/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found
Trying other mirror.
To address this issue please refer to the below knowledge base article

https://access.redhat.com/articles/1320623


If above article doesn't help to resolve this issue please open a ticket with Red Hat Support.


failure: repodata/repomd.xml from C7.0.1406-base: [Errno 256] No more mirrors to try.
http://vault.centos.org/7.0.1406/os/armhfp/repodata/repomd.xml: [Errno 14] HTTP Error 404 -Not Found

Hi am attempting to add a raspberry pi running centos7 as a slave. I just noticed its armv71, which must not be supported. Is there any way around this?

Highlighted

Re: No package ambari-agent available.

Contributor

@Roger Young

Could you please send me output of

yum install --disablerepo=* --enablerepo=Updates-ambari-2.2.2.0 ambari-agent

Highlighted

Re: No package ambari-agent available.

Expert Contributor

hi, i tried that command earlier, i cant remember the output but i still couldnt install ambari-agent after it. i dont think ambari supports armv71. I have since formatted the raspberry pi and added it to a basic hadoop cluster. i might try put ambari-agent on it again tomorrow

Don't have an account?
Coming from Hortonworks? Activate your account here