Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Node disconnection and nifi.zookeeper.connect.timeout settings

Highlighted

Node disconnection and nifi.zookeeper.connect.timeout settings

Expert Contributor

Hi All ,

I am getting the error of the node getting disconnected as there was no heatbeat from the node in 42 seconds. However I then changed the nifi.zookeeper.connect.timeout property to 60 seconds and restarted the Nifi server.

The problem is that despite this change I am still getting the disconnection error. Is there any other property that I need to set to fix this apart from the zookeeper.conect.timeout propery ??


1 REPLY 1

Re: Node disconnection and nifi.zookeeper.connect.timeout settings

Expert Contributor

Hi All , Apologies , I was looking at the wrong property. The property that I should had looked at is nifi.cluster.protocol.heartbeat.interval . I have now set this to 60 seconds and this has fixed my issue. However , I need to check if this has any issues to the overall performance

Don't have an account?
Coming from Hortonworks? Activate your account here