Support Questions

Find answers, ask questions, and share your expertise

Node fails to register while installing HDP 2.4.3. Only one node fails to register while all other nodes registration is success.



Please find the screen shot and error message displayed while registering HDP


Super Mentor

@saravanan gopalsamy

This error indicates that from your Ambari Server host the passwordless ssh is not properly setup for the Host where it is failing.

Please check if the "FQDN" for that host is correctly set for that host?

# hostname -f


Also check from amabri server host are you able to to password less ssh to that host?

# ssh root@problematic_host  


Use ssh-copy-id to copy public key file from Ambari server host to remote host. Check if the authorization_keys are properly setup to that host? or run the following command to push the ssh authorization key to that host again from ambari server host by running the following command:

 # ssh-copy-id -i ~/.ssh/  problematic_host  


And finally check if from the problematic host if you are able to ping or access the Ambari Server Hostname & Port ?

# nc  -v   $AMBARI_FQDN   8440
# nc  -v   $AMBARI_FQDN   8441


@Jay SenSharma The host which failed is ambari host.I tried these steps but still facing the same issue

Super Mentor

@saravanan gopalsamy

You will need to setup passwordless ssh to the ambari server host itself as well.

Along with a psswordless access to localhost as following: (so please try running the following commands on amabri server host) And also check the "hostname -f"

# ssh-copy-id -i ~/.ssh/  localhost
# ssh-copy-id -i ~/.ssh/  ambari.sierrainfosys.local
# hostname -f

.Also please check the user who is running the ambari server is "root" or non-root user. Accordingly the ssh key should be posted,

@Jay SenSharma Thank you..The issue is resolved.

Super Mentor

@saravanan gopalsamy

It will be also great if you can mark the answer as "Accepted" . Or if your solution varies the suggested one then please share the solution for the betterment of other HCC users.


@saravanan gopalsamy

You could as well do a manual registration by installing the ambari agent use appropriate OS commands

yum install -y ambari-agent

Then edit the ambari-agent.ini in /etc/ambari-agent/conf and point he hostname below to your ambari server


Start the ambari agent

# ambari-agent start

And retry it should register successfully

@Geoffrey Shelton Okot Is this applicable for the amabri host .. Amabri host Registration is the problem.The other nodes are registered successfully.

How ever i tried the solution provided by you but still there is a node registration failure in the same node.



@saravanan gopalsamy

Yes the ambari host should also have an agent running so the ambari-agent.ini should have an entry

These should have been the steps during your passwordless connection creation

# ssh-keygen 
# chmod 700 ~/.ssh 
# cat ~/.ssh/ >> authorized_keys
# chmod 600 ~/.ssh/authorized_keys 

Meanwhile did you check the permission on /root/.ssh it should be 700 and authorized_keys should be 600

@Geoffrey Shelton Okot Thank you ..The issue is resolved.

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.