Support Questions

Find answers, ask questions, and share your expertise

Not able to connect NIFI url


Hi ,

I am not able to connect nifi url.

Please fine the below log and help me on this.

2018-11-19 02:03:51,679 ERROR [Curator-Framework-0] o.a.c.f.imps.CuratorFrameworkImpl Background operation retry gave up org.apache.zookeeper.KeeperException$ConnectionLossException: KeeperErrorCode = ConnectionLoss at org.apache.zookeeper.KeeperException.create( at org.apache.curator.framework.imps.CuratorFrameworkImpl.checkBackgroundRetry( at org.apache.curator.framework.imps.CuratorFrameworkImpl.performBackgroundOperation( at org.apache.curator.framework.imps.CuratorFrameworkImpl.backgroundOperationsLoop( at org.apache.curator.framework.imps.CuratorFrameworkImpl.access$300( at org.apache.curator.framework.imps.CuratorFrameworkImpl$ at at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201( at java.util.concurrent.ScheduledThreadPoolExecutor$ at java.util.concurrent.ThreadPoolExecutor.runWorker( at java.util.concurrent.ThreadPoolExecutor$ at 2018-11-19 02:03:51,680 ERROR [Curator-Framework-0] o.a.c.f.imps.CuratorFrameworkImpl Background retry gave up org.apache.curator.CuratorConnectionLossException: KeeperErrorCode = ConnectionLoss at org.apache.curator.framework.imps.CuratorFrameworkImpl.performBackgroundOperation(


Master Guru
@Guru Prathap


NiFi clusters are dependent on Zookeeper (Zk) to be completely operational.

Zk is responsible for electing the NiFi Cluster Coordinator and Primary Node. So your NiFi nodes are trying to communicate with Zk to determine who has been elected for these roles so they can start sending heartbeats and join the cluster. The UI will not be available until this occurs.


If you are using the embedded Zk the above errors can be expected until enough embedded Zk have been started to create a Quorum. (recommend using external dedicated Zk cluster)

Your Zk should contain an odd number of servers (generally 3 or 5).


You may also want to adjust you Zk timeout values in the file. The defaults (3 secs) are typically to aggressive for real world setups. I suggest setting these to 30 - 60 secs.


Thank you,



If you found this answer addressed your question, please take a moment to login in and click the "ACCEPT" link.

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.