Support Questions
Find answers, ask questions, and share your expertise

Not able to login to Ambari dashboard. Sandbox Shutdown



I downloaded the HDP 2.3 VM.

I was using it perfectly fine. But many times I would shutdown the machine with Poweroff option of VM.

Now I am not able to login to Ambari dashboard.

I have uploaded the video here (1.5 mins) to show the issue

I have tried the following

  • sudo service ambari-server restart
  • sudo service ambari-agent restart
  • sudo /etc/init.d/postgresql restart

All service i can see says OK in terminal.

However when i login on dashboard with username password admin/admin

The dashboard just does not allow me to login. It stays at the same page after refreshing once.

  • How to fix this issue.
  • What is the correct step to stop VM.


Try to click "ctrl-shift-r" or "cmd-shift-r" on Mac at the ambari UI window. This will clear the cache on the browser. Also if that doesn't help, on the UI screen, right click and inspect element, see what happens when browser communicates with the ambari server. That should give you more insight into the problem. I always type "sudo shutdown now -h" to shutdown the VM.

After following @Artem Ervits' steps, you can bring up FireBug or Chrome Debugger and look for errors in the Console and Network tab.

@Saptak Sen

  • What is the correct step to stop VM.

I always use "x" then power off machine


Expert Contributor

I do a "shutdown now" from the console. Once that is complete I power off the VM.


sudo ambari-server restart

sudo ambari-agent restart

Cloudera Employee

It's hard to tell anything without any debug background in the question.

At the very beginning, you need to check browser debug messages and second mandatory option - check Ambari Server logs. Try to found something abnormal in the logs, like errors or warnings; these messages will help to us localize the problem

P.S. Power off option is not the best way in case of database presence on that host. Use shutdown command instead or shutdown (acpi method) option on your vm.

Do you have any errors in ambari-server.log ? Can you log into the DB using ambari/bigdata ?

New Contributor

I am getting the same error while login.

I am using Oracle virtual box on windows 7 and also have SQL server installed. Attaching the image:ambari-login-error.png