Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Not able to run again my custom processor.

Solved Go to solution
Highlighted

Not able to run again my custom processor.

image0.pngimage1.pngHello,

I am getting error in my custom processor, second time when I am going to start it is not starting and showing error not eligible component is selected, but I have selected processor and then trying to start. For your reference I have attached two images, in Image1 all processor are stopped and in Image2 I have selected my customprocessor and trying to start but getting message not eligible components are selected. Please let me know where I am doing mistake.

Thankyou

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Not able to run again my custom processor.

Expert Contributor
@Prakhar Agrawal

One of the reason could be the customprocessor is not stopped; your custom code is blocking and does not react to interrupts and hence you are not able to restart. One of the solution could be restart of Apache Nifi

View solution in original post

1 REPLY 1
Highlighted

Re: Not able to run again my custom processor.

Expert Contributor
@Prakhar Agrawal

One of the reason could be the customprocessor is not stopped; your custom code is blocking and does not react to interrupts and hence you are not able to restart. One of the solution could be restart of Apache Nifi

View solution in original post

Don't have an account?
Coming from Hortonworks? Activate your account here