Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Not able to run flume after CDH upgrade from 5.1 to 5.3

Not able to run flume after CDH upgrade from 5.1 to 5.3

Explorer

Hi, 

 

After upgradding cloudera from 5.1 to 5.3, I'm not able to start Flume-ng. 

This is happening only on Redhat 5 systems, fume is working well on Redhat 6.

 

It reports the following error. 

/opt/cloudera/parcels/CDH-5.3.5-1.cdh5.3.5.p0.4/lib/flume-ng/bin/flume-ng: line 239: /usr/bin/java: Argument list too long
/opt/cloudera/parcels/CDH-5.3.5-1.cdh5.3.5.p0.4/lib/flume-ng/bin/flume-ng: line 239: /usr/bin/java: Success

 

Value of the ARG_MAX is as folllows.

$ getconf ARG_MAX
131072

 

Could anyone help me fixing this problem ? 

I coudnt find much information on changing the ARG_MAX variable from internet, what is the recommended value for the same ? 

3 REPLIES 3
Highlighted

Re: Not able to run flume after CDH upgrade from 5.1 to 5.3

Explorer
Here is the stderr and stoudt. It seems like there are lot of duplicates appearing in the classpath.

Flume error log from agents directory. http://pastebin.com/wApRcLFp

Re: Not able to run flume after CDH upgrade from 5.1 to 5.3

New Contributor

Hi!

 

I've got same problem with you. Did you resolve this problem? 

 

I found what ulimit can change max arguments size, but it doesn't work.

 

If you already resolve this problem, please share about it.

Re: Not able to run flume after CDH upgrade from 5.1 to 5.3

Super Collaborator
Do you have your parcel directory under /opt/cloudera/parcels, or have you specified a custom directory location?

-pd