Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Not able to see HDP-3.0 version during installing HDP on VM Instance

Not able to see HDP-3.0 version during installing HDP on VM Instance

New Contributor

Hi,

I followed below link for installing latest HDP on VM instance,

https://docs.hortonworks.com/HDPDocuments/Ambari-2.7.1.0/bk_ambari-installation/content/select_versi...

As per the Hortonworks document, during selecting version we should see HDP-3.0. But I saw HDP-2.6.5.0 as the latest version in the list.

How to get the HDP-3.0 version for installing, Did I do any mistake during Ambari installation.

Please guide me to fix this issue.

Thanks,

Reddi Babu

7 REPLIES 7

Re: Not able to see HDP-3.0 version during installing HDP on VM Instance

Expert Contributor

@Reddi Vadlamudi

Please could you confirm which version of Ambari you are using to install HDP ?

Re: Not able to see HDP-3.0 version during installing HDP on VM Instance

New Contributor

Thanks for you response Jagadeesan,

I used Ambari 2.7.1.0 version.

Thanks,
Reddi Babu

Re: Not able to see HDP-3.0 version during installing HDP on VM Instance

Hi @Reddi Vadlamudi ,

I See you are using ambari-2.7.1 but unable to get the HDP-3.0 repo details on add cluster wizard.

confirm its ambari-2.7.10 itself using the command :ambari-server --version in ambari-server

for ex :

[root@anaikhdp1 ~]# ambari-server --version
2.7.0.0-897

Also if its same ambari as you mention please try to register the version with VDF file (fetch the VDF file for your version from here): https://docs.hortonworks.com/HDPDocuments/Ambari-2.7.1.0/bk_ambari-installation/content/hdp_30_repos...

refer to help here : https://docs.hortonworks.com/HDPDocuments/Ambari-2.7.1.0/bk_ambari-installation-ppc/content/import_t...

Re: Not able to see HDP-3.0 version during installing HDP on VM Instance

New Contributor

When I was trying to create cluster, once I click on create cluster image I saw the following error message,

Ambari Server / Web Client Version Mismatch

Ambari Server and Web Client versions do not match:

Ambari Server: 2.6.2.0
Ambari Web Client: 2.7.1.0

This typically happens after upgrading Ambari due to Ambari Web Client code cached in the browser.
Perform a hard browser cache refresh, typically 'Ctrl+Shift+R' ('Cmd+Shift+R' on OS X), to see if this message disappears.
If you keep seeing this message, clear the browser cache completely and hit this URL again.

You must resolve this error in order to continue.

Re: Not able to see HDP-3.0 version during installing HDP on VM Instance

Hi @Reddi Vadlamudi,

Looks like you have some left outs of last time and you have installed the ambari-server abouve it. is this a fresh install ?

your web client is 2.7.1.0 and ambari server is 2.6.2.0 .

its better to do a host cleanup and install a fresh version

Highlighted

Re: Not able to see HDP-3.0 version during installing HDP on VM Instance

New Contributor

When I was trying to create cluster after launching Ambari Web UI, I saw the below error message,

Ambari Server / Web Client Version Mismatch

Ambari Server and Web Client versions do not match:

Ambari Server: 2.6.2.0
Ambari Web Client: 2.7.1.0

This typically happens after upgrading Ambari due to Ambari Web Client code cached in the browser.
Perform a hard browser cache refresh, typically 'Ctrl+Shift+R' ('Cmd+Shift+R' on OS X), to see if this message disappears.
If you keep seeing this message, clear the browser cache completely and hit this URL again.
You must resolve this error in order to continue.

Please help me to resolve this issue.

Thanks,
Reddi Babu

Re: Not able to see HDP-3.0 version during installing HDP on VM Instance

New Contributor

Hi Akil,

Thanks for your response.

I verified ambari-server version, it is showing 2.7.1.0, I am using Ubuntu 16.0.

rvadlamudi@hdp3:~$ ambari-server --version
2.7.1.0-169

Thanks,

Reddi Babu

Don't have an account?
Coming from Hortonworks? Activate your account here