Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Not getting phoenix connection from spark after adding new host in cluster

Not getting phoenix connection from spark after adding new host in cluster

New Contributor

Hi, I had 10 nodes cluster running perfectly fine with Phoenix. I have added on new node in the cluster and have copied hbase-site.xml to spark conf directory, now all the spark config are in synch with each other. Any executor which is going on this new host is not able to connect to phoenix and is giving below error

java.sql.SQLException: ERROR 726 (43M10): Inconsistent namespace mapping properites.. Cannot initiate connection as SYSTEM:CATALOG is found but client does not have phoenix.schema.isNamespaceMappingEnabled enabled

I am able to login through squirrel and also from sqlline.py, all the regions are correctly distributed, still i am not able to use new host because of this.

Hdp version - 2.5.1.0

Hadoop - 2.7.3

Phoenix - 4.7.

Please help.

Thanks,

Prashant Verma

3 REPLIES 3

Re: Not getting phoenix connection from spark after adding new host in cluster

@Prashant Verma

Are you sending the phoenix jar location as part of your spark submit command? Could you confirm if phoenix client is correctly installed in the new host added?

Re: Not getting phoenix connection from spark after adding new host in cluster

New Contributor

@Felix thanks for replying, yes the Phoenix client jar is correctly installed and also added in spark submit command.

Thanks,

Prashant Verma

Re: Not getting phoenix connection from spark after adding new host in cluster

New Contributor

Need to add hbase-site.xml file in hadoop bin also, that solved my problem...thanks...