Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Null format with oracle metastore

Highlighted

Null format with oracle metastore

Contributor


hi all.


I 'm using a cluster with CDH5.1.2 and Oracle as metastore for Hive

I tried to create an external table with Hive using the following script:

 

CREATE external TABLE prova.test
(name String)
ROW FORMAT delimited fields terminated by ','
LINES TERMINATED BY '\n'
STORED AS TEXTFILE
LOCATION '/tmp/test' 
TBLPROPERTIES ('serialization.null.format'='');

 

after this, I cannot more access to table and to metastore.
This is the error: MetaException(message:Got exception: org.apache.thrift.transport.TTransportException java.net.SocketException: Broken pipe)

 

but when I create the table without the last line ( TBLPROPERTIES ('serialization.null.format'='') ), it works without errors

This is also reported also in this link:
http://www-01.ibm.com/support/docview.wss?uid=swg21667875


I tried also to delete the created tables but it is not possible. this is the error
Query: drop table ex_agqs1
ERROR: AnalysisException: Failed to load metadata for table: input.ex_agqs1
CAUSED BY: TableLoadingException: Failed to load metadata for table: input.ex_agqs1. Running 'invalidate metadata input.ex_agqs1' may resolve this problem.
CAUSED BY: TTransportException: null

I performed the invalidate command but the problem is not solved.

 

How can I fix this?
And how can I delete the already created tables ? because

 

 

Thanks 

Alessio

 

Don't have an account?
Coming from Hortonworks? Activate your account here