Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Older CDH install (CDH 5.14)

Older CDH install (CDH 5.14)

Explorer

Hi,

 

I am having issues with the new CDH 5.15, the Node Managers in YARN keeps randomly to give an "unexpected exit" error right after having installed the cluster, something I never had with CDH 5.12 -> 5.14

 

I would like to reinstall a brand new cluster with CDH 5.14 on Ubuntu (Xenial). I followed the documentation here:

https://www.cloudera.com/documentation/enterprise/5-14-x/topics/cdh_ig_install_previous.html

 

I used the following lines in the repo file:

 

deb [arch=amd64] https://archive.cloudera.com/cdh5/ubuntu/xenial/amd64/cdh xenial-cdh5.14.2 contrib
deb-src https://archive.cloudera.com/cdh5/ubuntu/xenial/amd64/cdh xenial-cdh5.14.2 contrib

 

But the Cloudera Manager keeps installing CDH 5.15 for some reason. 

 

Any help would be greatly appreciated. 

 

 

3 REPLIES 3
Highlighted

Re: Older CDH install (CDH 5.14)

Expert Contributor

Hi Julien,

 

If you are using the Cloudera Manager UI to install CDH to new hosts you do not need to edit the repo file.

 

Are you using the ADD CLUSTER wizard to add this cluster to your existing Cloudera Manager setup?   Or are you starting from scratch with a new Cloudera Manager installation, then logging into Cloudera Manager UI and letting the INSTALLATION wizard do the install for you?

 

What version of Cloudera Manager do you have?

Are you installing CDH parcels or packages?

 

Tina

Re: Older CDH install (CDH 5.14)

Explorer

Hi Tina,

 

Thank you!

Actually your reply made me realize I could simply update the Remote Parcel Repository URLs in the CM wizard. 

From there I could simply point to an older CDH version.

 

Thank again, now I don't have this YARN issue anymore. 

 

 

 

 

 

Re: Older CDH install (CDH 5.14)

Expert Contributor

Oh Great!   Glad that helped you realize the 'easy' way to install it.   :^)

Don't have an account?
Coming from Hortonworks? Activate your account here