Support Questions
Find answers, ask questions, and share your expertise

Only update Hive 3.1.0 to 3.1.2 on HDP 3.1.4 stack

Highlighted

Only update Hive 3.1.0 to 3.1.2 on HDP 3.1.4 stack

New Contributor

Hi,

Is it possible to update only the Hive component of HDP 3.1.4 stack without upgrading the whole stack ?

By default Hive is on 3.1.0 version on the stack, and I would like to upgrade it to 3.1.2 version (last minor stable version).

Any advice about this operation ?

Thank you for your help

3 REPLIES 3
Highlighted

Re: Only update Hive 3.1.0 to 3.1.2 on HDP 3.1.4 stack

New Contributor

Up, anyone please ?

Highlighted

Re: Only update Hive 3.1.0 to 3.1.2 on HDP 3.1.4 stack

Moderator

Hello @unkedeuxke ,

 

thank you for your enquiry about upgrading Hive 3.1.0 to 3.1.2 on HDP 3.1.4 without upgrading other components.

 

I would personally re-phrase the question:

- why is it only supported to upgrade the entire HDP stack instead of the services individually?

 

HDP is a distribution of various components bundled into a product. These components are tested against each other, so the distribution works reliably. Should you upgrade a single component only, you lose these guarantees that your HDP distribution will work. For instance think about API changes, new features or bugs being introduced. 

 

In short: you might able to upgrade a specific component however, it is not recommended because it might break things.

 

Hope this helps!

 

Best regards:

Ferenc


Ferenc Erdelyi, Technical Solutions Manager

Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.

Learn more about the Cloudera Community:

Highlighted

Re: Only update Hive 3.1.0 to 3.1.2 on HDP 3.1.4 stack

New Contributor

Hello @Bender ,

Thank you for your answer that is very clear.

Even HDP last version, which is 3.1.5, uses Hive 3.1.0 (not 3.1.2).

And Hive 3.1.2 should be a minor release to fix bugs from 3.1.0 version.

If I really want to "force" upgrade from 3.1.0 to 3.1.2, do you have any advice to proceed ? or any upgrade procedure ?

Thank you