Support Questions
Find answers, ask questions, and share your expertise

Oozie Shell Action Error: Incompatible minimum and maximum heap sizes specified

New Contributor

I tried to create and run oozie workflow with shell action like this:


<action name="shell-test">
  <shell xmlns="uri:oozie:shell-action:0.1">
  <ok to="end"/>
  <error to="kill"/>



But, always got the error: 
"Stdoutput Error occurred during initialization of VM
Stdoutput Incompatible minimum and maximum heap sizes specified"

The same workflow on CDH4.6.0 is working.


Super Collaborator

Did you recently upgrade Cloudera Manager?  If so, have you deployed client configs since then?  This is usually caused by the change that CM made to the HADOOP_CLIENT_OPTS to include both min and max heap sizes.  If you look in /etc/hadoop/conf/ you should see the following (assuming you've deployed client configs correctly):

export HADOOP_CLIENT_OPTS="-Xms268435456 -Xmx268435456 $HADOOP_CLIENT_OPTS"


On a side note, you can use the oozie 'fs' action to manipulate files and directories:


It is generally not recommended to use shell actions to run hadoop commands if it can be avoided by using native actions.


New Contributor

Thank you, for your reply. Yes, I did recently upgrade CM, but I didn't deploy client configs correctly. The problem has been solved. Thank you, for your recommendations.



FYI, when specifying duplicate Java command line options, the last one wins. So it's better to append (not prepend) -Xmx and -Xms to $HADOOP_CLIENT_OPTS.