Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Oozie UI is not accessible in kerberised cluster throwing 401-Authentication required

Oozie UI is not accessible in kerberised cluster throwing 401-Authentication required

Contributor

HDP version: 2.3.4.0, Ambari version: 2.2.0, Kerberized Cluster

I am not able to access oozie web ui (http://<oozieserverip>:11000) in browser. It is throwing HTTP Status:401 Authentication Required error.

I am not able to access oozie ui once I installed kerberos in cluster. Please advice a solution.

3 REPLIES 3

Re: Oozie UI is not accessible in kerberised cluster throwing 401-Authentication required

If you want to access a kerberos enabled UI, the computer who runs the browser needs to be in a trusted kerberos realm.

There are also some configuration settings you may have to do depending on the browser. But yeah Spnego is a bit of a pain in general. Especially because of the REALM requirement. Hue for example can be a way around that since it is username/password authenticated and has its own ticket.

http://www.microhowto.info/howto/configure_firefox_to_authenticate_using_spnego_and_kerberos.html

http://www.ghostar.org/2015/06/google-chrome-spnego-and-webhdfs-on-hadoop/

Re: Oozie UI is not accessible in kerberised cluster throwing 401-Authentication required

New Contributor

Hello @Vandana K R

I'm facing the same issue. I can't access any interface (NameNode UI, Oozie UI, ResourceManager UI ...) after enabling kerberos on my cluster. I've detailedly explained my problem here:

https://community.hortonworks.com/questions/147990/my-namenode-ui-is-not-accessible-on-my-kerbereize....

I didn't understand what does he mean in " the computer who runs the browser needs to be in a trusted kerberos realm"? What is the necessary configuration to do in order to ensure this suggestion? How did you resolve this issue?

I'll be really grateful if you could help me resolving this issue.

Re: Oozie UI is not accessible in kerberised cluster throwing 401-Authentication required

New Contributor

I have configured SPENGO authentication,But still we are facing same issue(HTTP Status 401 -Authentication required),Can you suggest me on this?