Support Questions
Find answers, ask questions, and share your expertise

Oozie error - HTTP Status 401

Contributor

Hello guys!

I'm trying to setup in hortonworks a tutorial from cloudera to create a pipeline to analyse twitter data .

I've managed to successfully configure flume and HDFS and now I'm trying to setup Oozie to run an ALTER TABLE command that adds a partition containing the last hour’s worth of data into Hive. However when I try to validate the process I get stuck in an error. Here's what I'm doing:

1. I create a new workflow and select import asset from shared file system:

15616-wf3.png

2. I select the file hive-action.xml - you can find the source code on github:

Github

15617-hiveaction.png

3. I fill the forms with the data from coord-app.xml and jobproperties:

15618-valworkflow.png

4. When I press validate:

15619-error.png

What can I possibly be doing wrong here?

Do I also need to create a coordinator?

Many thanks in advance!

Best regards!

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Oozie error - HTTP Status 401

Contributor

the problem was in the ip. Make sure you put hdfs:// ...

View solution in original post

4 REPLIES 4

Re: Oozie error - HTTP Status 401

Explorer

Is this a kerberos enabled cluster?

Also did you configure the oozie proxy user?

https://oozie.apache.org/docs/3.2.0-incubating/AG_Install.html#User_ProxyUser_Configuration

Re: Oozie error - HTTP Status 401

Contributor

Hello Amer and many thanks for your answer!

Kerberos is not enabled.

Hadn't configure the oozie proxy user but now I did (add the 2 properties with * as wildcard) but the problem persists 😞

What else can I be doing wrong? Best regards

Re: Oozie error - HTTP Status 401

Contributor

Managed to solve the problem via command line.

Now it gives me an error related with mapreduce:

org.apache.oozie.action.ActionExecutorException: JA009: Cannot initialize Cluster. Please check your configuration for mapreduce.framework.name and the correspond server addresses.

Re: Oozie error - HTTP Status 401

Contributor

the problem was in the ip. Make sure you put hdfs:// ...

View solution in original post