Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Oozie job stuck at Hive-shell.

Highlighted

Oozie job stuck at Hive-shell.

Contributor

Hi All, 

I am sunning Oozie job on the local sandbox.

I am stuck at the point, where I am executing Hive-job. Below is my flow,

 

start --> shell-action  -->  Pig-action --> Hive-action --> shell-action --> Hive-action --> end.

 

The problem is, my whole boh get executed until last hive job. I have looked into yarn logs, and I come to know Tez session not started yet. And my job still in running mode after almost 45mins.

Why this Tez session taking too much time to start ?? 

I tried this hive-action in hive-shell without Oozie workflow.

 

Logs:

 

INFO : Executing command(queryId=hive_xxxxxx_xxxxx_xxxx_xxx): < query_line1>.
.
.
<query_line_n>
INFO : Query ID = hive_xxxxxx_xxxxx_xxxx_xxx
INFO : Total jobs = 1
INFO : Launching Job 1 out of 1
INFO : Starting task [Stage-1:MAPRED] in serial mode
INFO : Subscribed to counters: [] for queryId: hive_xxxxxx_xxxxx_xxxx_xxx
INFO : Tez session hasn't been created yet. Opening session
End of LogType:stderr.This log file belongs to a running container (container_e03_xxxxxx_xxxx_xxx) and so may not be complete.

please kindly go through it and help me to resolve this issue.

 

Thanks,

Jay

Don't have an account?
Coming from Hortonworks? Activate your account here