Support Questions

Find answers, ask questions, and share your expertise
Announcements
Celebrating as our community reaches 100,000 members! Thank you!

Oozie not restarting

avatar

Hello,

I recently upgraded ambari to 2.4 did all the post upgrade stuff and now when im restarting services oozie fails and wont let me restart the other services. i thought it was a kerberos issue so i went to disable that since its not really needed and when it goes to shut down oozie it again fails. no idea why. below is the error out put. it seems to be looking for a file or configuration but i have no idea where it is located? any help would be appreciated.

Thanks in advance.

Traceback (most recent call last):
  File "/var/lib/ambari-agent/cache/common-services/OOZIE/4.0.0.2.0/package/scripts/oozie_client.py", line 76, in <module>
    OozieClient().execute()
  File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py", line 280, in execute
    method(env)
  File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py", line 680, in restart
    self.install(env)
  File "/var/lib/ambari-agent/cache/common-services/OOZIE/4.0.0.2.0/package/scripts/oozie_client.py", line 38, in install
    self.configure(env)
  File "/var/lib/ambari-agent/cache/common-services/OOZIE/4.0.0.2.0/package/scripts/oozie_client.py", line 45, in configure
    oozie(is_server=False)
  File "/usr/lib/python2.6/site-packages/ambari_commons/os_family_impl.py", line 89, in thunk
    return fn(*args, **kwargs)
  File "/var/lib/ambari-agent/cache/common-services/OOZIE/4.0.0.2.0/package/scripts/oozie.py", line 143, in oozie
    content=Template("oozie.conf.j2")
  File "/usr/lib/python2.6/site-packages/resource_management/core/base.py", line 155, in __init__
    self.env.run()
  File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line 160, in run
    self.run_action(resource, action)
  File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line 124, in run_action
    provider_action()
  File "/usr/lib/python2.6/site-packages/resource_management/core/providers/system.py", line 123, in action_create
    content = self._get_content()
  File "/usr/lib/python2.6/site-packages/resource_management/core/providers/system.py", line 160, in _get_content
    return content()
  File "/usr/lib/python2.6/site-packages/resource_management/core/source.py", line 51, in __call__
    return self.get_content()
  File "/usr/lib/python2.6/site-packages/resource_management/core/source.py", line 142, in get_content
    rendered = self.template.render(self.context)
  File "/usr/lib/python2.6/site-packages/ambari_jinja2/environment.py", line 891, in render
    return self.environment.handle_exception(exc_info, True)
  File "/var/lib/ambari-agent/cache/common-services/OOZIE/4.0.0.2.0/package/templates/oozie.conf.j2", line 35, in top-level template code
    {{oozie_user}}   - nproc    {{oozie_user_nproc_limit}}
  File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/config_dictionary.py", line 73, in __getattr__
    raise Fail("Configuration parameter '" + self.name + "' was not found in configurations dictionary!")
resource_management.core.exceptions.Fail: Configuration parameter 'oozie_user_nofile_limit' was not found in configurations dictionary!
1 ACCEPTED SOLUTION

avatar
Master Guru
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login
11 REPLIES 11

avatar
Master Guru

@steve coyle

e.g.

/var/lib/ambari-server/resources/scripts/configs.sh
-u <ambari-admin-username> -p <ambari-admin-password> set <ambari-server-hostname> <cluster-name> advanced-oozie-env oozie_user_nofile_limit 32000

You might get syntax error, please check help options 🙂

avatar

@Kuldeep Kulkarni

/var/lib/ambari-server/resources/scripts/configs.sh
-u <ambari-admin-username> -p <ambari-admin-password> set <ambari-server-hostname> <cluster-name> ozie-env oozie_user_nofile_limit 32000

and oozie_user_nproc_limit 16000 

had to remove the word advanced its just oozie-env 🙂 but its all working now! thank you soooooo much!!!

and thank you @Geoffrey Shelton Okot
for the help as well!!! you guys are awesome im very grateful for the help.