Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Oozie restart fails after upgrading ambari to 2.4.2.0

Solved Go to solution

Oozie restart fails after upgrading ambari to 2.4.2.0

New Contributor

Hi,

We have upgraded ambari from 2.2.2 to 2.4.2 and the oozie service fails to start with the issue: "Specified Oozie WAR '/usr/hdp/current/oozie-server/oozie.war' already contains ExtJS library files"

Full log:

stderr: 2017-03-21 15:33:22,368 - Unexpected Oozie WAR preparation output setting OOZIE_CONFIG=${OOZIE_CONFIG:-/usr/hdp/current/oozie-server/conf} setting CATALINA_BASE=${CATALINA_BASE:-/usr/hdp/current/oozie-server/oozie-server} setting CATALINA_TMPDIR=${CATALINA_TMPDIR:-/var/tmp/oozie} setting OOZIE_CATALINA_HOME=/usr/lib/bigtop-tomcat setting JAVA_HOME=/usr/lib/jvm/java-1.8.0-openjdk setting JRE_HOME=${JAVA_HOME} setting CATALINA_OPTS="$CATALINA_OPTS -Xmx8192m" setting OOZIE_LOG=/var/log/oozie setting CATALINA_PID=/var/run/oozie/oozie.pid setting OOZIE_DATA=/opt/hadoop/oozie/data setting OOZIE_HTTP_PORT=11000 setting OOZIE_ADMIN_PORT=11001 setting JAVA_LIBRARY_PATH=/usr/hdp/current/hadoop-client/lib/native/Linux-amd64-64 setting OOZIE_CLIENT_OPTS="${OOZIE_CLIENT_OPTS} -Doozie.connection.retry.count=5 " setting OOZIE_CONFIG=${OOZIE_CONFIG:-/usr/hdp/current/oozie-server/conf} setting CATALINA_BASE=${CATALINA_BASE:-/usr/hdp/current/oozie-server/oozie-server} setting CATALINA_TMPDIR=${CATALINA_TMPDIR:-/var/tmp/oozie} setting OOZIE_CATALINA_HOME=/usr/lib/bigtop-tomcat setting JAVA_HOME=/usr/lib/jvm/java-1.8.0-openjdk setting JRE_HOME=${JAVA_HOME} setting CATALINA_OPTS="$CATALINA_OPTS -Xmx8192m" setting OOZIE_LOG=/var/log/oozie setting CATALINA_PID=/var/run/oozie/oozie.pid setting OOZIE_DATA=/opt/hadoop/oozie/data setting OOZIE_HTTP_PORT=11000 setting OOZIE_ADMIN_PORT=11001 setting JAVA_LIBRARY_PATH=/usr/hdp/current/hadoop-client/lib/native/Linux-amd64-64 setting OOZIE_CLIENT_OPTS="${OOZIE_CLIENT_OPTS} -Doozie.connection.retry.count=5 " INFO: Adding extension: /usr/hdp/current/oozie-server/libext/falcon-oozie-el-extension-0.6.1.2.3.4.0-3485.jar INFO: Adding extension: /usr/hdp/current/oozie-server/libext/postgresql-jdbc.jar Specified Oozie WAR '/usr/hdp/current/oozie-server/oozie.war' already contains ExtJS library files Traceback (most recent call last): File "/var/lib/ambari-agent/cache/common-services/OOZIE/4.0.0.2.0/package/scripts/oozie_server.py", line 215, in <module> OozieServer().execute() File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py", line 280, in execute method(env) File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py", line 720, in restart self.start(env, upgrade_type=upgrade_type) File "/var/lib/ambari-agent/cache/common-services/OOZIE/4.0.0.2.0/package/scripts/oozie_server.py", line 88, in start self.configure(env) File "/var/lib/ambari-agent/cache/common-services/OOZIE/4.0.0.2.0/package/scripts/oozie_server.py", line 82, in configure oozie(is_server=True) File "/usr/lib/python2.6/site-packages/ambari_commons/os_family_impl.py", line 89, in thunk return fn(*args, **kwargs) File "/var/lib/ambari-agent/cache/common-services/OOZIE/4.0.0.2.0/package/scripts/oozie.py", line 185, in oozie oozie_server_specific() File "/var/lib/ambari-agent/cache/common-services/OOZIE/4.0.0.2.0/package/scripts/oozie.py", line 278, in oozie_server_specific prepare_war(params) File "/usr/lib/python2.6/site-packages/resource_management/libraries/functions/oozie_prepare_war.py", line 87, in prepare_war raise Fail(message) resource_management.core.exceptions.Fail: Unexpected Oozie WAR preparation output setting OOZIE_CONFIG=${OOZIE_CONFIG:-/usr/hdp/current/oozie-server/conf} setting CATALINA_BASE=${CATALINA_BASE:-/usr/hdp/current/oozie-server/oozie-server} setting CATALINA_TMPDIR=${CATALINA_TMPDIR:-/var/tmp/oozie} setting OOZIE_CATALINA_HOME=/usr/lib/bigtop-tomcat setting JAVA_HOME=/usr/lib/jvm/java-1.8.0-openjdk setting JRE_HOME=${JAVA_HOME} setting CATALINA_OPTS="$CATALINA_OPTS -Xmx8192m" setting OOZIE_LOG=/var/log/oozie setting CATALINA_PID=/var/run/oozie/oozie.pid setting OOZIE_DATA=/opt/hadoop/oozie/data setting OOZIE_HTTP_PORT=11000 setting OOZIE_ADMIN_PORT=11001 setting JAVA_LIBRARY_PATH=/usr/hdp/current/hadoop-client/lib/native/Linux-amd64-64 setting OOZIE_CLIENT_OPTS="${OOZIE_CLIENT_OPTS} -Doozie.connection.retry.count=5 " setting OOZIE_CONFIG=${OOZIE_CONFIG:-/usr/hdp/current/oozie-server/conf} setting CATALINA_BASE=${CATALINA_BASE:-/usr/hdp/current/oozie-server/oozie-server} setting CATALINA_TMPDIR=${CATALINA_TMPDIR:-/var/tmp/oozie} setting OOZIE_CATALINA_HOME=/usr/lib/bigtop-tomcat setting JAVA_HOME=/usr/lib/jvm/java-1.8.0-openjdk setting JRE_HOME=${JAVA_HOME} setting CATALINA_OPTS="$CATALINA_OPTS -Xmx8192m" setting OOZIE_LOG=/var/log/oozie setting CATALINA_PID=/var/run/oozie/oozie.pid setting OOZIE_DATA=/opt/hadoop/oozie/data setting OOZIE_HTTP_PORT=11000 setting OOZIE_ADMIN_PORT=11001 setting JAVA_LIBRARY_PATH=/usr/hdp/current/hadoop-client/lib/native/Linux-amd64-64 setting OOZIE_CLIENT_OPTS="${OOZIE_CLIENT_OPTS} -Doozie.connection.retry.count=5 " INFO: Adding extension: /usr/hdp/current/oozie-server/libext/falcon-oozie-el-extension-0.6.1.2.3.4.0-3485.jar INFO: Adding extension: /usr/hdp/current/oozie-server/libext/postgresql-jdbc.jar Specified Oozie WAR '/usr/hdp/current/oozie-server/oozie.war' already contains ExtJS library files

Can somebody help with this?

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Oozie restart fails after upgrading ambari to 2.4.2.0

Hi,

If you remove this component from the '/usr/hdp/current/oozie-server/oozie.war', you should be able to start the service:

zip -d oozie.war  ext-2.2/*

Regards,

ward

4 REPLIES 4

Re: Oozie restart fails after upgrading ambari to 2.4.2.0

Hi,

If you remove this component from the '/usr/hdp/current/oozie-server/oozie.war', you should be able to start the service:

zip -d oozie.war  ext-2.2/*

Regards,

ward

Re: Oozie restart fails after upgrading ambari to 2.4.2.0

New Contributor

Hi Ward, Thanks for the answer. Our colleague Sam managed to start the service by removing the ext2-2.js from the oozie war, like this: zip -d oozie.war ext-2.2/*

OR we can fix it by:

create a marker file in order to avoid running the prepare_war command with:

ls -l /libext | awk '{print , }' | awk 'NF > 0' > .war_libext_content

Re: Oozie restart fails after upgrading ambari to 2.4.2.0

Great thx!

Re: Oozie restart fails after upgrading ambari to 2.4.2.0

Rising Star

@Ward Bekker, why does that component have to be removed?

Don't have an account?
Coming from Hortonworks? Activate your account here