Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Oozie web console is disabled.

Solved Go to solution

Oozie web console is disabled.

New Contributor

oozie-error.jpg

Hi,

I installed hdp 2.6.5 cluster using two machines. It's not a kerberized environment. I'm using Chrome as a browser.

When Opening Oozie UI i get the following message :

Oozie web console is disabled.

To enable Oozie web console install the Ext JS library.

How can I enable the UI? Many thanks in advance.

Regards,

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Oozie web console is disabled.

Super Mentor

@Wael Horchani

There seems to be some issue with the "hdp-select" command as well.

Like i see an error when you are running the simple "hdp-select" command.

.

Also in your case the Oozie version might be slightly different (due to a slight different HDP version) so please check which repo is providing you oozie packages which are installed to your host:

# yum info oozie*

.

Also please make sure that the host where you are checking the Oozie is correct host. I means please verify by logging in to the Oozie server host using SSH using IP Address instead of using Hostname for SSH (as sometimes it might be possible that we use incorrect IP-Host mapping inside "/etc/hosts" entry on our local machine so that while doing SSH wee go to a different host)

.

7 REPLIES 7

Re: Oozie web console is disabled.

Super Mentor

@Wael Horchani

Please refer to the following Hortonworks HCC article to know how to fix that:

https://community.hortonworks.com/articles/61363/issue-oozie-web-console-is-disabledto-enable-oozie....

.

Basically you will need to check if "oozie.authentication.cookie.domain" property is added to your "Custom oozie-site" or not?

Also please check the following:

# wget http://archive.cloudera.com/gplextras/misc/ext-2.2.zip
# Stop Oozie service from Ambari
# Copy it to the path: "/usr/hdp/current/oozie-client/libext" AND "/usr/hdp/current/oozie-server/libext/" 
# Regenerate the war file by executing: $ /usr/hdp/current/oozie-server/bin/oozie-setup.sh prepare-war
# Start Oozie again

.

Re: Oozie web console is disabled.

New Contributor

Hi @Jay Kumar SenSharma,

Thank you for your answer. But the problem that I don't found any "oozie-server" directory as mentioned in the solved issue.

For this reason I mentioned earlier that my HDP version was 2.6.5 for this reason maybe there is some changes in the issue resolution for my case. The last one was in 2016.

My version of oozie is 4.2.0

Can you please give me updated and detailed steps to apply in my case (HDP 2.6.5 and OOZIE 4.2.0)

Many thanks in advance for your time and help.

Regards,

W-H

Re: Oozie web console is disabled.

New Contributor

Hi Jay,

Please find attached the screenshot where I tryied to find "oozie.war" file using root user.

Regards,

99493-oozie-server-not-found.jpg

Re: Oozie web console is disabled.

Super Mentor

@Wael Horchani

Ideally the path should exist in HDP 2.6.5 as well.
Example:

[root@newhwx3 ~]#  ls -ld /usr/hdp/current/oozie-client/libext
drwxr-xr-x. 2 root root 6 May 11  2018 /usr/hdp/current/oozie-client/libext

[root@newhwx3 ~]#  ls -ld /usr/hdp/current/oozie-server/libext/
drwxr-xr-x. 2 root root 6 May 11  2018 /usr/hdp/current/oozie-server/libext/

[root@newhwx3 ~]# hdp-select | grep oozie
oozie-client - 2.6.5.0-292
oozie-server - 2.6.5.0-292

.


Can you please check if you have the Oozie package installed properly?

# yum info oozie_2_6_5_0_292*


If not installed properly then you can try reinstalling it as following

# yum reinstall oozie_2_6_5_0_292*

.

Path to Oozie WAR:

[root@newhwx3 ~]# locate oozie.war
/usr/hdp/2.6.5.0-292/oozie/oozie.war
/usr/hdp/2.6.5.0-292/oozie/webapps/oozie.war

[root@newhwx3 ~]# ls -l /usr/hdp/2.6.5.0-292/oozie/webapps/oozie.war
-rw-r--r--. 1 root root 0 May 11  2018 /usr/hdp/2.6.5.0-292/oozie/webapps/oozie.war

.

Re: Oozie web console is disabled.

New Contributor

Dear @Jay Kumar SenSharma ,

I am very surprised, and I have the impression that I have miss something.

By the first hand, there is no trace of OOZIE in the cluster.

By the second hand, i'm very sure that i select it during the installation and it's displayed by Ambari as UP.

I don't know what i should do !!

Regards,

99494-oozie-not-found-1.jpg

99495-oozie-not-found-2.jpg

99496-oozie-not-found-3.jpg

Re: Oozie web console is disabled.

Super Mentor

@Wael Horchani

There seems to be some issue with the "hdp-select" command as well.

Like i see an error when you are running the simple "hdp-select" command.

.

Also in your case the Oozie version might be slightly different (due to a slight different HDP version) so please check which repo is providing you oozie packages which are installed to your host:

# yum info oozie*

.

Also please make sure that the host where you are checking the Oozie is correct host. I means please verify by logging in to the Oozie server host using SSH using IP Address instead of using Hostname for SSH (as sometimes it might be possible that we use incorrect IP-Host mapping inside "/etc/hosts" entry on our local machine so that while doing SSH wee go to a different host)

.

Re: Oozie web console is disabled.

New Contributor

Hi @Jay Kumar SenSharma,

I perform a fresh installation of the cluster hdp 2.6.5.

I follow steps mentioned and it works now :) Many Thanks for your help.

Regards,