Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here. Want to know more about what has changed? Check out the Community News blog.

Oozie workflow error JA009: Cannot initialize Cluster. Please check your configuration for mapreduce

Highlighted

Oozie workflow error JA009: Cannot initialize Cluster. Please check your configuration for mapreduce

Explorer

I am running the workflow in the cloudera quickstart vm 5.7.2 I am able to run the job from the command line but then in hue it just freezes gives the error  JA009: Cannot initialize Cluster. Please check your configuration for mapreduce.

 

Here is my workflow.xml 

 

<workflow-app name="sample-workflow" xmlns="uri:oozie:workflow:0.5">
<global>
<job-tracker>${jobTracker}</job-tracker>
<name-node>${nameNode}</name-node>
</global>

<start to="sshScript"/>

<action name="sshScript">
<shell xmlns="uri:oozie:shell-action:0.3">
<job-tracker>${jobTracker}</job-tracker>
<name-node>${nameNode}</name-node>
<exec>hello.sh</exec>
<argument>44 </argument>
<file>/user/cloudera/hive-config.xml#hive-config.xml</file>
</shell>
<ok to="end"/>
<error to="fail"/>


</action>

<kill name="fail">
<message>Failed script</message>
</kill>
<end name='end'/>

</workflow-app>

 

and my job.properties

 

oozie.use.system.libpath=True
security_enabled=False
dryrun=False
queueName=default
nameNode=quickstart.cloudera:8020
jobTracker=quickstart.cloudera:8032
oozie.libpath=/user/hue/oozie/workspaces/sampleScript/
oozie.wf.application.path=/user/hue/oozie/workspaces/sampleScript/workflow.xml

 

 

Thanks