Support Questions
Find answers, ask questions, and share your expertise
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Oracle JDBC connection issue

Oracle JDBC connection issue

New Contributor

Hi Team


We are trying to connect to Oracle DB in Sqoop using JDBC connector but receving below error. We even tried to set the below property in the sqoop command but not able to resolve the issue. Any solution to this issue is really helpful.


sqoop list-tables"\"+ 




19/04/03 14:35:18 WARN sqoop.ConnFactory: Parameter --driver is set to an explicit driver however appropriate connection manager is not being set (via --connection-manager). Sqoop is going to fall back to org.apache.sqoop.manager.GenericJdbcManager. Please specify explicitly which connection manager should be used next time.
19/04/03 14:35:18 INFO manager.SqlManager: Using default fetchSize of 1000
19/04/03 14:35:18 DEBUG manager.SqlManager: No connection paramenters specified. Using regular API for making connection.
19/04/03 14:35:18 ERROR manager.SqlManager: Error reading database metadata: java.sql.SQLRecoverableException: IO Error: Connection reset
java.sql.SQLRecoverableException: IO Error: Connection reset
at oracle.jdbc.driver.T4CConnection.logon(
at oracle.jdbc.driver.PhysicalConnection.<init>(
at oracle.jdbc.driver.T4CConnection.<init>(
at oracle.jdbc.driver.T4CDriverExtension.getConnection(
at oracle.jdbc.driver.OracleDriver.connect(
at java.sql.DriverManager.getConnection(
at java.sql.DriverManager.getConnection(
at org.apache.sqoop.manager.SqlManager.makeConnection(
at org.apache.sqoop.manager.GenericJdbcManager.getConnection(
at org.apache.sqoop.manager.SqlManager.listTables(
at org.apache.sqoop.Sqoop.runSqoop(
at org.apache.sqoop.Sqoop.runTool(
at org.apache.sqoop.Sqoop.runTool(
at org.apache.sqoop.Sqoop.main(
Caused by: Connection reset


Re: Oracle JDBC connection issue

Rising Star

Please try explicitly specifying the --connection-manager in your sqoop command (if you already tried this, please share the full sqoop command).

Also make sure the driver is installed.