Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Overwriting Guava Library in Flume

Overwriting Guava Library in Flume

New Contributor

Hi everyone, I'm working on a flume implementation that integrates with software using guava 19.0. Given that flume appears to use guava 11.0, I had to overwrite flume's guava library with the latest one. There doesn't appear to be any issues, but I'm concerned that I've broken something without realizing it. Anyone know why flume uses such an old version of guava?