Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Permission Denied when trying to create directory

Permission Denied when trying to create directory

New Contributor

Hi,

 

I have installed CDH 5.

 

I am trying to create a directory to load a CSV file into HDFS. here are the commands I tried :

 

$whoami

impala

 

$id

uid=479(impala) gid=474(impala) groups=474(impala), 482(hive),488(hdfs)

 

$ hdfs dfs -ls /

$ hdfs dfs -ls /

Found 4 items

drwxr-xr-x    -    hbase hbase              0 2016-06-07 11:28 /hbase

drwxrwxr-x  -        solr   solr                 0 2016-06-06 09:43 /solr

drwxrwxrwx -      hdfs supergroup       0 2016-06-06 09:57 /tmp

drwxr-xr-x    -      hdfs supergroup       0 2016-06-06 09:58 /user

 

$ hdfs dfs -mkdir -p /user/staging/tab1

mkdir : Permission denied: user=impala, access=WRITE, inode="/user":hdfs:supergroup:drwxr-xr-x

 

Do I have to create the directory as hdfs, since only hdfs seems to have permission to /user

 

 

 

 

 

 

1 REPLY 1

Re: Permission Denied when trying to create directory

Expert Contributor
Hi dbanj,

yes, the permissions look like you need to be 'hdfs' to create the folder.
Have you tried this? Did it work?

Cheers, Lars
Don't have an account?
Coming from Hortonworks? Activate your account here