Support Questions
Find answers, ask questions, and share your expertise

Phoenix query issue

I have set up a cluster in Ambari.

I am using Aqua Data Studio to connect hbase using "org.apache.phoenix.jdbc.PhoenixDriver" drive to connect through ZK nodes.

I can run normal queries on hbase tables, but it throws an error while running any aggregate function like max()/count()

>[Error] Script lines: 6-10 ------------------------- org.apache.phoenix.exception.PhoenixIOException: The system cannot find the path specified  [Executed: 23/12/2016 11:47:19 AM] [Execution: 28ms]

What I need to do to fix this issue?


Super Mentor

@rudra prasad biswas

What is the path set for "" ?

Also can you please stare the complete stackTrace?

Also on your Aqua data studio side do you have the proper client configuration files placed in the classpath? (like

hbase-site.xml file)

@Jay SenSharma

I just checked from Ambari Metrics/Configs/Metric Collector/Advanced ams-hbase-site/

it's: ${hbase.tmp.dir}/phoenix-spool

In Aqua Data Stufio, I have the jar files: hbase-client.jar;phoenix-client.jar;hbase-client-;phoenix-4.9.0-HBase-1.2-client.jar

Super Mentor

@rudra prasad biswas

- Can you please share the complete stackTrace?

- Also the Classpath setting that you shared contains Semi Colon separated values which indicates that you might be using Windows Environment on the client side, So i will suggest you to please go through the following article which talks about a similar issue on Windows:

@Jay SenSharma

As I mentioned above that's the error I get in Aqua Data Stdio console. Apart from that there is nothing getting logged.

Hi @rudra prasad biswas

Can you validate you have hbase-site.xml, core-site.xml and hdfs-site.xml in the classpath? Also what version of HDP are you running?

"I just checked from Ambari Metrics/Configs/Metric Collector/Advanced ams-hbase-site/" are you trying to connect to the AMS HBase/Phoenix instance? Not the HBase service?

What about the value of hbase.tmp.dir? That property value would be substituted in It defaults to "/tmp" if you do not have it set. This directory must exist and be writable by the user running the Phoenix queries.