Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Pivotal HDB/HAWQ latest version 2.1.0 install fails on HDP v2.5, with the following ERROR

Re: Pivotal HDB/HAWQ latest version 2.1.0 install fails on HDP v2.5, with the following ERROR

New Contributor

Hi Leonard,

I would need the URL that you used to download HDP 2.4 VM. Is your sandbox using docker or vagrant?

Re: Pivotal HDB/HAWQ latest version 2.1.0 install fails on HDP v2.5, with the following ERROR

New Contributor

I Lav, I downloaded the HDP 2.5 VM version (NOT 2.4!) from the Hortonworks download site. It is already integrated with Docker and Linux V7.

Re: Pivotal HDB/HAWQ latest version 2.1.0 install fails on HDP v2.5, with the following ERROR

New Contributor

Leonard, I was referring to your last message on Dec 20, where you mentioned that you were unable to initialize HAWQ 2.0.1 with HDP 2.4 VM. Let me try installing HAWQ with HDP 2.5 VM sometime this week.

Re: Pivotal HDB/HAWQ latest version 2.1.0 install fails on HDP v2.5, with the following ERROR

New Contributor

Hi Lav en Leonard; I encountered the exact same issue in the exact same circumstances. We noticed the 2.5 sandbox has Centos 7 as OS. This may be the root cause of the error. Please advise when Centos 7 support will be available. Meanwhile you can try to use the HDP 2.4 sandbox that includes Hawq; you can download it here.

Re: Pivotal HDB/HAWQ latest version 2.1.0 install fails on HDP v2.5, with the following ERROR

Contributor

CentOS 7 / RHEL 7 support is being worked on and will be available in about a month or two. You can always check the support matrix in Release Notes here: http://hdb.docs.pivotal.io

Highlighted

Re: Pivotal HDB/HAWQ latest version 2.1.0 install fails on HDP v2.5, with the following ERROR

New Contributor

Hi Janssens, thanks for the link to the HDB HAWQ download on VMWARE.

I already have an Oracle Virtualbox machine setup (.ova VM files) and would like to continue with this VM stack. Therefore, I would appreciate if you could send me the link to the Oracle Vm (.ova) download files.

Many Thanks,

Re: Pivotal HDB/HAWQ latest version 2.1.0 install fails on HDP v2.5, with the following ERROR

New Contributor

Hi Leonard, there is unfortunately no VirtualBox version. I resolved the issue eventually differently. I downloaded the HDP 2.4 sandbox and followed the instructions on

https://community.hortonworks.com/articles/39997/installing-hawq-on-2400-hortonworks-sandbox.html

using a Pivotal HDB 2.0.0 download (this works nicely!), but I suppose a more recent version would do too (note that the packaging differs in that case)

Upgrading HDP in the sandbox is not possible. The only alternative to get the latest configuration is to set up a HDP 2.5 cluster on centos6 and to add the latest HDB binaries.

Re: Pivotal HDB/HAWQ latest version 2.1.0 install fails on HDP v2.5, with the following ERROR

Contributor

All - I just uploaded new HDB 2.1.1 sandbox images running on HDP 2.5 on CentOS 6. Please give that a try and let me know if all works well:

https://network.pivotal.io/products/pivotal-hdb

Re: Pivotal HDB/HAWQ latest version 2.1.0 install fails on HDP v2.5, with the following ERROR

New Contributor

Hi Vineet, thanks for uploading the revised version of HDB2.1.1 on CentOS 6.

However, there are two things that must be addressed, to allow me to evaluate HDB2.1.1 effectively, as follows:

1) HAWQ has the capability to interface with both HIVE and HBASE - but HBASE is currently NOT installed in the sandbox. ADDITIONALLY, when I try to install the embedded service, the INSTALL (Hbase Master) FAILS !!

.......
2017-01-25 20:25:17,360 - call returned (1, '/etc/hadoop/2.5.3.0-37/0 exist already', '')
2017-01-25 20:25:17,360 - checked_call[('ambari-python-wrap', '/usr/bin/conf-select', 'set-conf-dir', '--package', 'hadoop', '--stack-version', '2.5.3.0-37', '--conf-version', '0')] {'logoutput': False, 'sudo': True, 'quiet': False}
2017-01-25 20:25:17,381 - checked_call returned (0, '')
2017-01-25 20:25:17,382 - Ensuring that hadoop has the correct symlink structure
2017-01-25 20:25:17,382 - Using hadoop conf dir: /usr/hdp/current/hadoop-client/conf
2017-01-25 20:25:17,385 - checked_call['hostid'] {}
2017-01-25 20:25:17,388 - checked_call returned (0, '000a0f02')
2017-01-25 20:25:17,392 - Version 2.5.3.0-37 was provided as effective cluster version.  Using package version 2_5_3_0_37
2017-01-25 20:25:17,393 - Package['hbase_2_5_3_0_37'] {'retry_on_repo_unavailability': False, 'retry_count': 5}
2017-01-25 20:25:17,548 - Installing package hbase_2_5_3_0_37 ('/usr/bin/yum -d 0 -e 0 -y install hbase_2_5_3_0_37')

Command failed after 1 tries

2) Please confirm whether MADLIB (for Machine Learning using SQL) is fully installed - if NOT, please direct me to instructions on installing MADLIB (v1.9 ???) within HAWQ 2.1.1.

Many Thanks !

Re: Pivotal HDB/HAWQ latest version 2.1.0 install fails on HDP v2.5, with the following ERROR

Contributor

1) Can you check your repos in Ambari to see what repo is it pointing to, and perhaps changing them to point to HDP public repo instead to install additional components?

2) MADlib should already be installed (I haven't checked though). More info here:

http://hdb.docs.pivotal.io/211/hdb/install/install_package_extensions.html#installmadlib

Don't have an account?
Coming from Hortonworks? Activate your account here