Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Post Command Fails in Apache atlas 0.8

Highlighted

Post Command Fails in Apache atlas 0.8

New Contributor

Recently, I have installed HDP 2.6.1 on 3 node cluster to test new features of Apache Atlas and Ranger. When i ran import-hive.sh I am getting this issue.

Exception in thread "main" org.apache.atlas.hook.AtlasHookException: HiveMetaStoreBridge.main() failed.
        at org.apache.atlas.hive.bridge.HiveMetaStoreBridge.main(HiveMetaStoreBridge.java:650)
Caused by: com.sun.jersey.api.client.ClientHandlerException: java.net.SocketTimeoutException: Read timed out


Hbase, Kafka, Solr all services are running fine. After doing a lot of configuration changes in Atlas and other services, i haven't got any success.later on i tried request module of python. It seems that "get" requests are working well. "post" is giving issue.

Few question I have:

1. I am able to create Tags and associate tag to Default database so ideally "admin" user has privilege to create delete and update entities.

2. Same should work for rest API, But why only "get" is working. Why not "post"

Thank you,

Subash

3 REPLIES 3

Re: Post Command Fails in Apache atlas 0.8

Rising Star

Can you add complete logs from import-hive and the application.log for atlas too ?

Re: Post Command Fails in Apache atlas 0.8

New Contributor

Can you please share the post command?

Re: Post Command Fails in Apache atlas 0.8

Rising Star

Did you get past the issue ?