Support Questions
Find answers, ask questions, and share your expertise

Problem completing the tutorial Pig Risk factor analysis.

New Contributor


i ve been doing the tutorial Pig risk factor analysis but on the last step,where i run the whole pig script,i get an error,and of course the data are not stored in the risk factor table.I have already tried the solutions found on here but nothing of these tackled the problem. Any ideas?

Thank you


@Asimakis Nikolaou

Could you share the link for risk factor analysis? Also share me the scripts and error which you have used.

To add few points on pig, Even though you have many lines in pig scripts. It will be compiled only when the whole scripts are called or when commands like dump, store are used. So there are chances that the error may occurred at any point of the line.

New Contributor

@Bala Vignesh N V

Yes, the pig script is the one used in the following link:

I am aware that there is a type problem with the totmiles,but i already changed it,but it doesnt help at all.

The error i am getting is - ERROR 0

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.