Support Questions
Find answers, ask questions, and share your expertise

Problem during Ambari Confirm Hosts

Solved Go to solution

Re: Problem during Ambari Confirm Hosts

Contributor

DNS has been configured but I still got an error message. One of the nodes I got the initial error I posted and the other I got the second error. What do you mean by leverage the /etc/hosts? @Neeraj Sabharwal

Highlighted

Re: Problem during Ambari Confirm Hosts

@Mark Thorson

Make sure that you modify the ambari.ini for agents to point to correct ambari server. Link

/etc/ambari-agent/conf/ambari-agent.ini has ambari server address

Highlighted

Re: Problem during Ambari Confirm Hosts

Contributor

Alright sounds good. Just to confirm the hostname I should enter would be the server Ambari is running on? Also would the hostname be the FQDN or the DNS name of the server? @Neeraj Sabharwal

Highlighted

Re: Problem during Ambari Confirm Hosts

Contributor

I had success during the "confirm hosts" stage for one of the servers. During the install I received the attached error message stating it requires fuse but I am unsure what this is. @Neeraj Sabharwal

ambari-install-error.txt

Highlighted

Re: Problem during Ambari Confirm Hosts

Contributor

I retried the install and the error message did not appear this time. I was able to set up one of the two new servers with a couple warnings.

I tried to manually install the other server the same way but am getting a blank error message just stating the registration failed. When I look at the repolist something doesn't seem right here. It doesn't look like the table shown in the reference guide. @Neeraj Sabharwal

hadoop-support-ambari.jpg

Registering with the server...
Registration with the server failed.
Highlighted

Re: Problem during Ambari Confirm Hosts

@Mark Thorson Let me confirm

1) You are installing ambari server in one of the nodes

2) You are manually installing agent in all the nodes

I won't worry about table yet.

You should go ahead and do the install

yum install ambari-server

and yum install ambari-agent --> in all nodes

Highlighted

Re: Problem during Ambari Confirm Hosts

Contributor

@Neeraj Sabharwal Yeah that is correct. I have installed Ambari Server on 1 node and Ambari Agent on all 3. The image below is the 3rd server. When I attempt to perform manual registration for this server I get an error message saying the code below.

Registering with the server...
Registration with the server failed.

2397-hadoop-support-ambari-yum-install.jpg

Highlighted

Re: Problem during Ambari Confirm Hosts

@Mark Thorson Good news!!! :) We have agent there already

modify ini file and add ambar server address then ambari-server start

Highlighted

Re: Problem during Ambari Confirm Hosts

Contributor

@Neeraj Sabharwal To confirm you mean the ini file on the machine running Ambari Server? I previously had the 3 servers listed in the ini file. Does Ambari Server require a restart after they have been added?

2399-hadoop-support-ambari-ini.jpg

Highlighted

Re: Problem during Ambari Confirm Hosts

@Mark Thorson /etc/ambari-agent/conf/ambari-agent.ini

The ini file in 3rd server.

What step are you on now?