Support Questions
Find answers, ask questions, and share your expertise

Problem using local repository

Problem using local repository

Explorer

I've found this question in this forum but without a proper solution for this. I am currently using Cloudera Manager 5.5.1 on Ubuntu 14.04. I have configured a local repository following the details mentioned in the documentation. The repository is working fine and can be accessed through browser.

 

So I have created two repositories, one for the cm and other for the cdh by downloading from the following URLs

1) http://archive.cloudera.com/cm5/repo-as-tarball/

2) http://archive.cloudera.com/cdh5/repo-as-tarball/

 

The installation of cloudera manager server is done and I can log into the admin console by going to http://my.system.ip.address:7180

 

Now while adding a host I only found option for placing  the CM5 repository information but not the CDH5 repo. And it always try to fetch it from the remote URLs. If the connection is slow the process hungs in the middle and nothing seems to work. Most importantly every single time the server overwrite the repository URL under /etc/apt/sources.list.d/ folder pointing to the remove location.

 

Is this a problem with the cloudera manager itself or I am doing some thing wrong. 

Fetching from the remote URLs causes the process to be very unstable and aborting in the middle sometimes makes the admin console stop working. The only way to get it back is to manually start/stop the server.

 

Any help please?

 

1 REPLY 1
Highlighted

Re: Problem using local repository

Explorer

Is there any one atleast care to tell me if I am doing something terribly wrong here? Or is this just the expected behavior? Any one please