Support Questions
Find answers, ask questions, and share your expertise

Problems with the Metadata Server WEB UI

New Contributor

I am facing a Warning message with the Metadata server. The Error message: http://localhost:21000/api/atlas/admin/status is 0.00s Service Unavailable.

And indeed the port does not respond to connection (telnet localhost 21000).

The /var/log/atlas/application.log contains the following error:

- Context initialization failed (ContextLoader:350)

- org.springframework.beans.factory.BeanCreationException: Error creating bean with the name 'org.springframeworkcontext.event.internalEvemtListenerProcessor': BeanPostProcessor before .......



Factory method 'get' threw exception.

I have zookeeper working on four nodes,atlas, hbase and ambari-infraSolr installed in two of the nodes (the three softwares are installed in the same two nodes). There are no errors or warnings inside the Solr WEB UI Console and the zookeeper and HBASE seems to work OK.

Can you give me a clue what to check in order to find the problem? I tried to delete the three services (HBASE,ambari-infraSolr and Atlas ) and reinstall them, without any influence on the problem that continue to exist.





Zookeeper would always need to run on odd no of nodes to form a quarum. Have you tried cleaning up the nodes and doing a fresh install ? and by the way which version of HDP are you trying to install ?

New Contributor

I am using HDP

Yes, I cleaned the nodes and did a fresh re-installation receiving the same problem, again.

About the zookeeper, I will delete zookeeper from one of the nodes, so it will be installed on three of them.

Please notice that the Atlas Metadata Server is up, only the WEB UI server is down and not responding.

When I reading the immense and complex log file, there is another message that probably may help:

.... Caused by: org.springframework.beans.factory.BeanCreationException: Error creating bean name 'get' defined in org.apache.atlas.repository.graph.AtlasGraphProvider: Bean instatiation via factory method failedl nested exception is com.thinkaurelius.titan.core.TitanException: Could not open global configuration.