Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Proxy.pac setting for Ambari-Server

Proxy.pac setting for Ambari-Server

Explorer

I wanna setup my ambari-server to use proxy.pac by following the steps in the official document(

https://docs.hortonworks.com/HDPDocuments/Ambari-2.1.2.1/bk_ambari_reference_guide/content/_how_to_s...

Adding the following to "/var/lib/ambari-server/ambari-env.sh." didn't help and the Ambari-server fails to find others

nodes by FQDN names.

-Dhttp.proxyHost=192.168.XXX.XXX.pac -Dhttp.proxyPort=XXXX

2 REPLIES 2
Highlighted

Re: Proxy.pac setting for Ambari-Server

@Yu Song

Can you please elaborate more on what did not work? Are you getting any error or exception after applying the http proxy settings?

Following is an example, shows how we can apply it

export AMBARI_JVM_ARGS=$AMBARI_JVM_ARGS' -Xms512m -Xmx2048m -Djava.security.auth.login.config=/etc/ambari-server/conf/krb5JAASLogin.conf -Djava.security.krb5.conf=/etc/krb5.conf -Djavax.security.auth.useSubjectCredsOnly=false -Dhttp.proxyHost=your.example.com -Dhttp.proxyPort=8888' 
Highlighted

Re: Proxy.pac setting for Ambari-Server

Explorer

The reason trying to use proxy.pac setting is that, by default, proxy setup tries to resolve a domain name on WAN and Ambari-server fails to resolve the FQDN names specified during the cluster nodes registration.

With proxy.pac, system tries to resolve a FQDN at LAN level then, if necessary, on WAN.

In a hope that proxy.pac will make it work I've added the following line to the bottom of

file "/var/lib/ambari-server/ambari-env.sh."

-Dhttp.proxyHost=proxyIP.pac -Dhttp.proxyPort=XXXX

However, Ambari-server still couldn't seem to resolve the specified FQDN names.

Don't have an account?
Coming from Hortonworks? Activate your account here